Strange Optical drive problem

squareyes squareyes at
Thu Nov 6 06:54:39 UTC 2008

Nigel Henry wrote:
> On Wednesday 05 November 2008 13:35, squareyes wrote:
>> Nigel Henry wrote:
> Hi Winton. Sorry that didn't work, but thinking about it my distro wouldn't 
> boot with the cdrom drive in first place in the boot ordering, so a different 
> problem to yours.
> The fact that neither XP, or Ubuntu can see the optical drive seems to 
> indicate a BIOS problem, or some setting that needs to be changed for the 
> optical drive in the BIOS. It's worth a good look through the various menu 
> items in your BIOS.
> For example, and the mobo I have on this pc is going to be different to yours, 
> but the "Main" menu item in the BIOS shows IDE Configuration.
> The mobo has 1 IDE controller which can handle 2 drives (master, and slave), 
> and 4 SATA controllers, 2 of which have harddrives connected to them.
> Looking at Primary IDE Master, this shows the optical drive [ATAPI  DVD A 
> DH21]. Down arrow to this entry, and enter, and there's a bunch of info for 
> the optical drive, plus the ability to change some stuff as below.
> Type: (currently set to auto), but has options also for CDROM, and ARMD 
> (whatever that is.
> PIO Mode: (currently set to auto, but with 5 options as alternatives to auto).
> DMA Mode: (currently set to auto, and a whole bunch of options).
> If the optical drive is seen in the BIOS, it's worth trying different DMA 
> Modes. Auto should work, but maybe sometimes you have to set a specific mode.
> I'm not doubting the output from lshw, but have a look at dmesg in a terminal. 
> It's a long file, and my optical drive shows up some  2/3rds down the file.
> Also have a look in the /dev directory/folder. Depending on what your optical 
> drive is capable of, you may see symlinks for cdrom, cdrw, dvd, and dvdrw. In 
> my case these symlinks are all pointing to hda, which is the block device for 
> the optical drive. This is with Kubuntu Gutsy Gibbon 7.10.
> With Hardy Heron 8.04, the same symlinks above point to scd0, which again is 
> the block device for the optical drive, but due to changes, newer kernels, 
> libata is now being used, and all block devices are now viewed as scsi 
> devices, hence the reason that my optical drive on GG is shown as hda, but on 
> HH, is shown as scd0.
> None of the above may be of any help to you. It would be nice to have your 
> laptop in front of me, and I could play around with it. Such is not the case 
> though, and I feel a bit like the blind leading the blind.
> Sorry I can't be more positive in helping you to resolve your problem.
> Nigel.
Hi Nigel,
many thanks for your efforts, have attached output of dmesg,
can't see any reference to scd at all, appears "No block devices found"

The bios doesn't seem to have any settings to access cdrom drive settings.
Main  - System time
        System date
Quiet Boot - (enabled)
Network Boot - (enabled)

Advanced  Legacy USB support - (enabled)
          Modem  (enabled)
          SATA ControllerMode Option  - (Compatability)
                                         Other option AHCI.
 Needs to be set to "Compatability" to "See" the Hard Drive to install, 
have tried both options
after install, same result.

Device folder

squareyes at here:/media$ ls
cdrom  cdrom0
squareyes at here:/media$ mount /cdrom
mount: special device /dev/scd0 does not exist (understandable)

Weather here is warming up, your welcome to move here (South Australia) 
for a couple of weeks if you would really care to have this machine in 
front of you. No white Christmases here, 30° C here today and it's 
looking like we will have a very hot summer :-)

Again many thanks
take care
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: dmesg
URL: <>

More information about the ubuntu-users mailing list