problem with nvidia geforce2 mx200

Karl Larsen k5di at
Sat May 31 11:32:02 UTC 2008

Bram Kuijper wrote:
> Hi all,
> during the regular updates, my nvidia-glx package was updated last 
> Wednesday. Since that moment, Xorg is not able to load the glx module 
> anymore and only runs in safe graphics mode.

> However, my nvidia-glx driver is installed normally:
> $ dpkg -l | grep nvidia
> ii  nvidia-glx 
> 1:96.43.05+                         NVIDIA binary XFree86 
> 4.x/X.Org driver
> rc  nvidia-glx-dev 
> 1:96.43.05+                         NVIDIA binary XFree86 
> 4.x/X.Org driver devel
> rc  nvidia-glx-legacy                          71.86.04+ 
>                            NVIDIA binary XFree86 4.x/X.Org 'legacy' dri
> ii  nvidia-kernel-common                       20051028+1ubuntu8 
>                            NVIDIA binary kernel module common files
> ii  nvidia-kernel-source 
> 1:96.43.05+                         NVIDIA binary kernel 
> module source
> ii  nvidia-settings                            1.0+20080304-0ubuntu1 
>                            Tool of configuring the NVIDIA graphics driv
> I also tried to get my graphics card working with the EnvyNG tool. It 
> installed nvidia-glx-new next to nvidia-glx, but rebooting after that 
> still did not solve the problem.
> 	I have a version of 7.10 that is bad like yours. I tried re-doing the xorg.conf to no avail. So I re-loaded 7.10 on another partition and it has been good.
    Here is my new load:
karl at karl-desktop:~$  dpkg -l | grep nvidia
ii  nvidia-glx-new                             
100.14.19+             NVIDIA binary XFree86 4.x/X.Org 
'new' driver
ii  nvidia-kernel-common                       
20051028+1ubuntu7                    NVIDIA binary kernel module common 
karl at karl-desktop:~$

    What happened was as soon as it first came up it asked me if I 
wanted a non-ubuntu files and I said yes. When I re-booted the Desktop 
was pretty and the system has been stable. Here is my /etc/X11/xorg.comp 
file today:
Section "Device"
        Identifier      "nVidia Corporation C51G [GeForce 6100]"
        Driver          "nvidia"
        Busid           "PCI:0:5:0"
        Option          "AddARGBVisuals"        "True"
        Option          "AddARGBGLXVisuals"     "True"
        Option          "NoLogo"        "True"

Section "Monitor"
        Identifier      "Generic Monitor"
        Option          "DPMS"
        Horizsync       28-64
        Vertrefresh     43-60

Section "Screen"
        Identifier      "Default Screen"
        Device          "nVidia Corporation C51G [GeForce 6100]"
        Monitor         "Generic Monitor"
        Defaultdepth    24
        SubSection "Display"
                Modes           "1280x1024"     "1280x960"      
"1024x768"     "832x624"        "800x600"       "720x400"       "640x480"

Section "ServerLayout"
        Identifier      "Default Layout"
  screen "Default Screen"
        Inputdevice     "Generic Keyboard"
        Inputdevice     "Configured Mouse"

        # Uncomment if you have a wacom tablet
        #       InputDevice     "stylus"        "SendCoreEvents"
        #       InputDevice     "cursor"        "SendCoreEvents"
        #       InputDevice     "eraser"        "SendCoreEvents"
Section "Module"
        Load            "glx"
karl at karl-desktop:~$

    You might try the Ubuntu nVidia driver and see if it will write a 
clean xorg file for you.

    By the way it is a pain to work on the small screen. I about went 
nuts :-)



	Karl F. Larsen, AKA K5DI
	Linux User
   PGP 4208 4D6E 595F 22B9 FF1C  ECB6 4A3C 2C54 FE23 53A7

More information about the ubuntu-users mailing list