Problem with unzip task in nant

Aquil H. Abdullah aquil.abdullah at
Wed May 28 23:49:59 UTC 2008

I just upgraded to Ubuntu 8.04 TLS (Schaweeet!)

Anyway, I am having a problem with nant.  When I attempt to execute the
unzip task I get the following stack trace:

System.NotSupportedException: CodePage 437 not supported
  at System.Text.Encoding.GetEncoding (Int32 codePage) [0x00000]
  at NAnt.Compression.Tasks.UnZipTask.get_Encoding () [0x00000]
  at NAnt.Compression.Tasks.UnZipTask.ExecuteTask () [0x00000]
  at NAnt.Core.Task.Execute () [0x00000]

Please send bug report to nant-developers at

I can unzip the file using unzip from the command-line.  I haven't tried
building nant from scratch yet, but it looks like that is what I am going to
have to do to track down the problem....Unless someone out here has already
solved this issue :)


Aquil H. Abdullah
aquil.abdullah at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list