ubuntu 8.04 libc6 problem

Mike Bird mgb-ubuntu at yosemite.net
Sun May 18 20:03:07 UTC 2008


On Sun May 18 2008 12:45:41 Barry Bass wrote:
> I'm trying to use gcc in ubuntu 8.04, but apparently libc6-dev is not
> installed. Using Synaptic Package Manager to try and install it I get the
> error message:
>
>         libc6-dev:
>         Depends: libc6 (=2.6.1-1ubuntu10) but 2.7-10ubuntu3 is to be
>                  installed
>
> I would interpret this to mean that the version of libc6 that is installed
> is not compatible with the version of libc6-dev it would otherwise
> install.
>
> This would mean to me that the versioning needs to be fixed. Even trying
> "Force Version" to load the available version of libc-dev does not load
> the package.
>
> Does anyone have a work around? Is this problem otherwise known and being
> repaired?

I'm assuming you have libc6 version 2.7-10ubuntu3 installed.  You can use
"dpkg -s libc6" to verify this.

Try "sudo apt-get install libc6-dev=2.7-10ubuntu3" to see if it can find
the version of libc6-dev which matches your libc6.

Otherwise you'll probably have to update libc6 and then install libc6-dev.

--Mike Bird




More information about the ubuntu-users mailing list