External Hard drive problem

chris dunn chris at citci.biz
Mon May 5 20:43:05 UTC 2008

On Mon, 5 May 2008 18:56:41 +0100

John K Masters <johnmasters at oxtedonline.net> wrote:

JKM> On 12:45 Mon 05 May     , Linda Hanigan wrote:
JKM> > On Mon, 2008-05-05 at 18:11 +0100, John K Masters wrote:
JKM> > > On 11:54 Mon 05 May     , Linda Hanigan wrote:
JKM> > > > I am hoping someone can help me. I have a seagate 500gb
JKM> > > > external usb hard drive. It has a NTFS filessystem. I was
JKM> > > > backing up to it last week and caught the power cord so it
JKM> > > > was the equivalent of turning it off so it was not unmounted.
JKM> > > > Now the drive is not recognized by Windows or Linux. I tried
JKM> > > > doing mount -t ntfs-3g /dev/sda1 /media/free. I tried using
JKM> > > > -o force. Can anyone help me it says it can't find a drive on
JKM> > > > sda1 so I don't know if I can even reformat it.
JKM> > > > 
JKM> > > What do you get if you connect it to your Linux box and run:-
JKM> > > 
JKM> > > sudo fdisk -l
JKM> > > 
JKM> > > After connecting try:- dmesg
JKM> > > 
JKM> > > Does that show anything? I don't really know too much about
JKM> > > NTFS but hopefully you haven't damaged the actual drive
JKM> > > 
JKM> > fdisk -l only shows hda nothing for sda and there is nothing in
JKM> > dmesg it is like you didn't plug anything in.
JKM> >               Linda
JKM> > 
JKM> Just to eliminate the obvious, if the disk is mains powered does it
JKM> spin up when switched on? If it is powered through the USB port,
JKM> have you tried another cable?

I've just trashed a Maxtor external 500gb USB hard drive in circumstances 
similar but not identical to yours.

My box stopped recognising the drive at all. Nothing I could do would make it 
aware of the drive's existence.

Reading around I found a lot of comments about failures of external hard 
drives being much more frequent than with the internal flavour.

That being so, I took someones advice and prised open the case, to find inside 
a regular 500gb internal hard drive. Extracted it, mounted it as an internal 
IDE drive, and bingo, a working drive and all the data on it was intact.

I can only conclude that the small circuit board inside the external drive 
that I guess converts the drive from ATA to a USB connector was fried. So no 
more external drives for me.

Chris Dunn

More information about the ubuntu-users mailing list