Can't unmount

John Hubbard ender8282 at
Sat May 3 00:53:34 UTC 2008

The other day I mounted my home directory (/home/jhubbard) from my 
server on my laptop as /home/jhubbard/home.  Now I can't un-mount it.  I 
can't remember how I mounted it.  It is shared as both a NFS share and a 
Samba share.  When my laptop is connected to the home network I can 
browse the folder, but otherwise I get problems.  (An >ls -l of my 
laptops home directory hangs if I can't see the server.)
I have tried :
jhubbard at jhubbard-laptop:~$ umount /home/jhubbard/home/
umount: /home/jhubbard/home is not mounted (according to mtab)
jhubbard at jhubbard-laptop:~$ smbumount /home/jhubbard/home
/home/jhubbard/home probably not smb-filesystem
jhubbard at jhubbard-laptop:~$ umount jhubbard-server:/home/jhubbard/home/
umount: jhubbard-server:/home/jhubbard/home/ is not mounted (according 
to mtab)
jhubbard at jhubbard-laptop:~$ umount jhubbard-server:/home/jhubbard
umount: jhubbard-server:/home/jhubbard is not mounted (according to mtab)

I also tried an rm -rf /home/jhubbard/home and I wiped my home directory 
on my server.  At least I had a backup that was only a day or two old. 
Does anyone know what I have to do to unmount the share and make the 
folder go away. 
BTW autofs is not installed.  I haven't tried a reboot yet but if 
someone thinks that it will help I will try it. 

Any thoughts? 


To be or not to be, that is the question
                2b || !2b
(0b10)*(0b1100010) || !(0b10)*(0b1100010)
        0b11000100 || !0b11000100
        0b11000100 || 0b00111011
        255, that is the answer.

More information about the ubuntu-users mailing list