Why doesn't GUI upgrade 6.10 to 7.04 work as documented?

Kipton Moravec kip at kdream.com
Thu Mar 27 21:39:32 UTC 2008

On Thu, 2008-03-27 at 16:13 -0500, Kipton Moravec wrote:
> I searched how to upgrade Ubuntu 6.10 to 7.04 and got two hits almost
> exactly the same instructions,
> http://www.ubuntugeek.com/upgrade-ubuntu-610-edgy-eft-to-ubuntu-704-feisty-fawn-2.html
> http://onlyubuntu.blogspot.com/2007/03/upgrade-ubuntu-610-edgy-eft-to-ubuntu.html
> I looked on www.Ubuntu.com and could not find how to upgrade other than
> download the CD.
> Here were the instructions I followed:
> ======================================
> Upgrading Ubuntu Edgy to Ubuntu Feisty
> Method 1 - Using GUI
> If you want to upgrade using GUI use the following command
> gksu “update-manager -c ”
> “-c” switch tells it to look for upgrades at all.
> You should see the following screen here Now you can see 7.04 is
> available for upgrade click on upgrade.
> =====================================
> I opened a terminal window (I thought it was a GUI method).
> and typed:
> gksu “update-manager -c ”
> this message was displayed:
>   warnings.warn("apt API not stable yet", FutureWarning)
> Then the software updates screen appeared similar to what the web page
> showed, but there was no option to click to upgrade to 7.04. It says my
> system is up to date.
> What did I do wrong? This should be simple.
> Kip 

Looking farther I found this page:

typing into a terminal window:
dpkg -l update-manager

I get:
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err:
||/ Name           Version        Description
ii  update-manager 0.42.2ubuntu22 GNOME application that manages apt

So it looks like I have 0.42.2 not 0.45.2 as it says I need to do the

The instructions say:
If you only want to update the update-manager package, open
System/Administration/Synaptic Package Manager and click on "Search",
then type "update-manager". Verify in the "Latest Version" column that
0.45.2 is available and install it. If it is not available click on
"Reload". If it is still not available after a reload, open
Settings/Repositories and make sure that the "Internet
Updates/Recommended updates" checkbox is checked. After a reload the
update package will be available. 

Mine says only 0.42.2 is available. Since there was a
update-manager-core not installed, I installed it.

It did not make a difference.

I tried Reload and it is still not available.

I opened Settings/Repositories went to "Internet Updates"
and there were three check boxes:

Check for updates automatically "Daily"
Download Updates in the background, but do not install them
Install Security Updates without conformation

The first two were checked the last was not. 
I do not see "Internet Updates/Recommended updates" anywhere.

All my channels in Synaptic Package Manager say Ubuntu 6.06 LTS. Is that
the problem? I thought the upgrade would update that.


Kipton Moravec KE5NGX
"Always do right; this will gratify some people and astonish the rest."
--Mark Twain

More information about the ubuntu-users mailing list