screen resolution not changeable

michael MichaelLinux at
Tue Jun 24 20:06:32 UTC 2008

Hi Michael,

thanks for your reply.

1. I can enabled Advanced Desktop Effect

2.when starting the display-applet, I see following at the terminal:
	awk: cannot open /var/log/Xorg.1.log (No such file or directory)
	warning: failed to get module paths from '/var/log/Xorg.1.log' -
falling back to default
	Xlib:  extension "XFree86-VidModeExtension" missing on display
  but setting and testing another resolution failes. It seems that only 
  the current resolution is working.

I don't understand what went wrong when updating, because with 7.10 all
worked fine, I could adjust every resolution and had now performance
In worst case I have to wait for Ubuntu 8.10 ...


Am Mittwoch, den 18.06.2008, 18:59 -0400 schrieb Michael Haney:
> On Wed, Jun 18, 2008 at 12:15 PM, michael <MichaelLinux at> wrote:
> > Hello,
> >
> > Ijust upgraded from Ubuntu 7.10 to 8.04. When restarting I was in a kind
> > of restricted mode which suggests me to select a graphic driver. But
> > this doesnt help. So I used Envyng to install the my ATI drivers. Then
> > the boot was ok, the screen has a resolution of 1280x800. But I have
> > still some problems with display/graphics/drivers.
> >
> I recently had a resolution problem which I finally resolved myself
> after a crap load of research.  One way to see if the ATI drivers are
> installed is to see if you can enabled Advanced Desktop Effect in the
> Appearance applet on the Preferences menu.  If you can do this the
> drivers are installed because GLX can't run without the drivers
> working.
> > 1.If I want to change the screens resolution I get:
> >        The X Server does not support the XRandR extension.  Runtime
> >        resolution changes to the display size are not available.
> > Why this?
> >
> I got no clue.  I tried running xrandr on my laptop to fix my
> resolution problem and it didn't return any errors, and it didn't help
> my problem none either.
> > 2.I don't see the ATI driver in the restricted drivers menu.
> > Is it still not installed somehow?
> >
> I think Hardware Drivers (jockey-gtk) only shows drivers which are
> downloadable from the repositories.  I tried the drives from EnvyNG
> for my Nvidia card and Hardware Drivers said they weren't installed
> when I knew they were because GLX was working.  Now do the ATI drivers
> appear in Hardware Drivers but aren't checked and its status is Not In
> Use or is it just not there?
> If you installed the drivers via EnvyNG the driver in Hardware Drivers
> will "appear" as if its not installed when it really is.
> > 3. The overall performance its now very poor, I guess thats also linked
> > to that graphics driver mess.
> >
> That I don't know about.  If was only using the generic frame
> buffer I'd that's the reason, but if your resolution is very high
> right now I'd say the ATI drivers are working.
> > Who can help me?
> >
> I will try.  One thing you can do is run "sudo displayconfig-gtk" from
> a Terminal window, this is the old Screen Resolution applet from the
> Preferences menu in Gutsy which is still in Hardy.  This is what
> helped me with my resolution problem, I was stuck at 640x480 and
> couldn't change it until I used that applet.  You should be able to
> tame your display settings with this.
> -- 
> Michael "TheZorch" Haney
> thezorch at
> AIM: thezorch at
> Yahoo IM: zorchhaney
> ICQ: 343230252
> GoogleTalk: thezorch
> MSN Messeger: haneymichael at

More information about the ubuntu-users mailing list