No sound after the latest update

NoOp glgxg at
Thu Jun 5 17:13:09 UTC 2008

On 06/04/2008 02:26 PM, Miguel Daniel Rodríguez Magarzo wrote:
> Hi list,
> I am not sure whether this problem happened after a single daily update
> or maybe after a automated kernel update, since generally I don't pay
> much attention about which updates are running, just let the system to
> do it. But the sound went off just after that update.
> This is a laptop Thinkpad T42 with a 2.6.24-18-generic kernel, Ubuntu
> 8.04. 
> Trying to open the volume control applet (which appears with the
> non-operative symbol, e.g. a white cross over a square red background),
> it says something similar to this:
> There were no GStreamer volume control devices found.
> "No se han encontrado complementos o dispositivos control de volumen de
> GStreamer."
> On the other hand, if we go to System > Preferences > Sound, and
> clicking in the first button ("To try") trying to listen some sound
> event, it gives me the following:
> audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample !
> gconfaudiosink: Failed to connect stream: Invalid argument
> Other buttons give similar warning, and there, just below at the end,
> there is no sound device to select!
> I think this bug:
> and this one:
> are saying the same, but those were reported months ago, I don't know
> its status or whether they were eventually solved.
> Is someone able to clear something at this, please?

I had just the opposite problem; exact same symptoms on a Intel LCH
snd_intel8x0 (and same error messages etc) - however it works with
2.6.24-18-generic but not with 2.6.24-18-386. I resolved it by:

sudo apt-get install linux-386

More information about the ubuntu-users mailing list