Wireless network problem after upgrade to 8.04

Derek Broughton news at pointerstop.ca
Wed Jun 4 12:40:26 UTC 2008

Ken McLennan wrote:

> G'day there One & All,
>     I was recently running 7.10 without problem. It worked like a charm
> out out of the box, detected all hardware including my Intel(R)
> PRO/Wireless 3945ABG wireless network card and connected reliably
> without problem.

Connected to what?

> I followed the 
> suggestions I found and changed from "roaming" to the settings I wanted
> - Ad-Hoc network using dhcp with no password. I also added a
> "wireless-mode Ad-Hoc" line to /etc/networks/interfaces. All without
> success.

That's why I asked the above question.  If you are using DHCP, I can't see
how you can be using "Ad-hoc".  A wireless adapter connecting to a wireless
access point/router should always be in "managed" mode.  Putting _anything_
in /etc/network/interfaces defeats Network Manager.

>     I followed other instructions that I found here & there without
> success. I then swore & cursed loudly with the same result. "iwconfig
> eth1 mode Ad-Hoc" continually got error messages about the device being
> busy. The network-config gui told me that eth1 didn't exist, and showed
> no address; eth1-avahi gave an address but whenever I pinged from there
> I was told it didn't exist.

You don't want that anyway.  It's a zeroconfig address that has absolutely
no value I've ever found.


More information about the ubuntu-users mailing list