saving flv files streamed over rtmp

andy baxter andy at
Sun Jul 27 02:28:55 UTC 2008

Sven wrote:
> On 07/27/2008 12:09 AM, andy baxter wrote:
>> hello,
> Hi Andy
>> is there a way to save flv files that are streamed using rtmp? I want to 
>> record a flash video that is being streamed in this way, but can't see a 
>> way to do it in linux. There seem to be solutions for windows, so there 
>> must be a way of doing it. Mplayer won't play these streams, which is 
>> what I tried first.
> Through Google I found an interesting thread on Linuxquestions[0] about 
> your problem.
> In summary you need to install a Windows software and run it in Wine 
> emulation. There seems to be no other way.
> === Wikipedia ===
> Orbit Downloader is a free, closed source, graphical download manager 
> for the Microsoft Windows operating system. One of the main features of 
> the program is its ability to grab and download embedded Flash Video 
> files from sites like YouTube, Dailymotion, Metacafe etc. Orbit 
> Downloader also accelerates downloads by acting as a peer-to-peer 
> client, utilising bandwidth of other users.
> Orbit Downloader supports the following protocols:
>      * HTTP
>      * HTTPS
>      * FTP
>      * Metalink
>      * RTSP (Real-Time Streaming Protocol)
>      * PNM (rename PNM to RTSP)
>      * MMS (Microsoft Media Services)
>      * NSS (rename NetShow Services to MMS)
>      * RTMP (Real Time Messaging Protocol)
> Other people run successful Orbit Downloader in Wine (see Wine AppDB[1])
Thanks for the advice. I have tried this first by sniffing the stream 
using wireshark and looking for the rtmp url being requested, then 
trying to download this directly in orbit downloader. This doesn't work 
- the server rejects the connection saying 'access denied'.

I also tried installing the windows versions of firefox and flash inside 
wine, and running wine firefox at the same time as orbit 'grab it' which 
is supposed to detect rtmp urls as they are streamed (and apparently 
does work for the site I'm interested in in windows). I started playing 
the video in firefox and nothing appeared in the 'grab it' window, so 
this approach doesn't seem to work either.

A couple of things occurred to me about the second approach:

- there could be a problem in that I started the two programs (grab it 
and firefox for windows) in separate wine invocations. However only one 
instance of wineserver is started, so this is probably not the problem.
- also, I've noticed that the only way to get wireshark to sniff eth0 is 
by starting it as root, so maybe I need to change some permissions 
somewhere to allow ordinary users to do this, which may make grab it 
work properly as well?


More information about the ubuntu-users mailing list