UpdateManager Ate My Soundcard!

Bart Silverstrim bsilver at chrononomicon.com
Thu Jul 3 12:56:00 UTC 2008

David Armour wrote:
> The story so far/update:
> Following a mostly-routine Update Manager process finished, about a week
> ago now, I found my Hardy desktop had become mute. At the time, error 
> messages suggested that I was missing a variety of gstreamer plug-ins that
> synaptic listed as installed. Go figure. Aplay -l, however, showed no sound 
> cards! Up-date manager ate my soundcard!
> After  sudo apt-get install gdm ubuntu-desktop, aplay -l now shows:
> **** List of PLAYBACK Hardware Devices ****
> card 0: SI7012 [SiS SI7012], device 0: Intel ICH [SiS SI7012]
>   Subdevices: 0/1
>   Subdevice #0: subdevice #0
> ...and media programs such as Rhythmbox play .mp3 files, although the vol-
> ume controls have complexified, inexplicably. The panel applet modifies the 
> sound output less predictably than before, and seems to require fiddling with 
> more audio icons than just the panel applet.
> The log out/log in sounds play when tested, but the nifty panel timer applet
> flashes completion but doesn't play the ambulance sound file. And CBC's au-
> dio streams are still missing although -- the other google recommendation  -- 
> I *have*  libflashsupport installed.
> No dice! What next, Ollies?

I just had a similar issue, right after an update! Weird.

I had to go in and keep playing with mixer settings until I could get 
the ALSA control to my sound card chipset (and not the USB mics from 
webcams) working. Seemed to pop up when I ran the alsamixer (is that the 
console utility for controlling an alsa device with an ncurses 
interface?); I ran it at the console, suddenly sound returned.

I had to install libflashsupport to get Firefox working with Youtube, 
though. It looked like it didn't previously have that installed. Did you 
try completely removing then reinstalling libflashsupport?

More information about the ubuntu-users mailing list