One Way Samba-Solved-Now Broke Again-Fixed again

Leonard Chatagnier lenc5570 at
Sun Feb 24 01:44:50 UTC 2008

--- NoOp <glgxg at> wrote:

> On 02/21/2008 03:06 PM, Leonard Chatagnier wrote:
> > But it's not mounting now as shown above refering
> to
> > the wrong IP ADDR. Using the right IP, 192.168.1.
> > 65 works.  If anyone can offer some suggestions to
> get
> > my hostname to refer to the current IP and not the
> one
> > before I reconfigured the maching when it was
> > "kubuntu-desktop" and hard wired, I'd be most
> > grateful.
> > Thanks, NoOp for trying. I appreciate it,
> > 
Note: this is cleared up since resetting the router,

> Here are a couple of general rules that I typically
> follow when setting
> a small home/business DSL network - they may be of
> help, or maybe not &
> others will certainly have their own preferences.
> 1. I ensure that all the fixed computers have fixed
> IP's that are not on
> the same subnet as the gateway router. If for
> example the gateway is
>, then my machines would be say
> and the
> gateway would be Many routers/modems use
>, so I
> make sure to avoid the 192.168.1.x subnet
> altogether. It just makes life
> easier & avoids any possible mistakes in the subnet.
Don't have the choice here with my gateway 1701HG
combo. AAMOF, 2Wire tech support said I couldn't use
static IP's as I purchased dhcp. But got that straight
with 2nd level tech support, partly anyway.
> 2. 
Snip Big

> For your existing problem(s) I'd recommend that you
> check your router
> settings and clear out any previous dhcp address'
> that have been
> previously issued. If the router still has the mac
> address & IP of one
> of your newly reassigned fixed IP's, then there will
> be a conflict.
Yes, after clearing the router any reference to or kubuntu-desktop(hostname) went away.

> 3. I normally rely on my router for dhcp, firewall,
> fqdn updates, etc.,
> so I also generally put the DSL modem in bridge mode
> depending upon the
> type of DSL modem. For example a Speedstream 5100B
> can cause all sorts
> of problems with dhcp & links when VNC's are used.
> Setting to bridge
> mode and allowing the router to do it's job works
> considerably better.
2Wire tech support says bridge mode not available for
me; heck, what do I know. I don't think I'm using
VNC's or VPN's so should be ok.

> 4. On the Ubuntu machines; go into each one on the
> network settings and
> actually enter the IP Address & Alieses of each of
> the fixed machines
> (System|Administration|Network|Hosts|Add). If
> necessary, check the
> /etc/host file and add them there, example (modified
> for the purposes of
> this post of course):
> localhost mycomputer.mshome
> mycomputer
> # The following lines are desirable for IPv6 capable
> hosts
> ::1 ip6-localhost ip6-loopback
> fe00::0 ip6-localnet
> ff00::0 ip6-mcastprefix
> ff02::1 ip6-allnodes
> ff02::2 ip6-allrouters
> ff02::3 ip6-allhosts
> myothercomputer
> my-laptop
> mytestserver
> mywindowsmachine
> myserver

This all done on both machines and both machines

> 5. For Gutsy machines: remove & purge apparmor - at
> least until the bugs
> with cups & pdf-printer etc., are worked out.
> Besides, apparmor is
> primarily an enterprise security application & I've
> found that (for now
> anyway) that it is much more trouble than it is
> worth in a small home
> network.
Done that on both machines.

> 6. Don't mess with command line automount smbf
> unless you actually have
> a reason to do so. I have all of my machines set to
> automatically show
> the neighbor shares icon on the desktop and in
> Nautilus & if the other
> machine is alive it automounts just by clicking on
> the icon or the
> machine folder in Nautilus.
>   It's really quite easy to do, all you do is
> Places|Connect to
> Server|Windows Share| then:
> Server: (example)
> Name to use for connection: MyOtherMachine
> - Connect
> Bingo, I now have a desktop icon to MyOtherMachine
> and in Nautilus I
> have a network MyOtherMachine network folder.
> If I reboot or logout, the icon and network folders
> come up automatically.
OK. Using dolphin or nautilus is the way I want to go
anyway and much easier for me to do. Thanks.
> 7. If I have a problem connecting to a
> smb://machinename then I can
> almost always connect using the machine IP address.
> If it's failing on
> machinename, then I go back and check #4.
No longer an issue the last time I did a mount.

> 8. For connecting to a Windows drive (reboot or
> otherwise), follow the
> instructions in
> pretty much to
> the letter. Works for me.
Got the reference in case I need it. I now just use
linux on both machines if their not broke.
OK. After getting a reply to my inquiry on how to
setup static IP's I followed the email directions from
2wire and lost all cnnections to the gateway. Couldn't
even connect from vista or repair it in vista. Called
ATT DSL tech support and they fixed vista, but first
line said I couldn't use static IP's. Didn't believe
it. Went to level 2 and after some disagreement on
whether I could do this with my router, he went
through the vista setup and finally got it set. He
didn't have an easy job of it, either. Ok, now booting
into vista or ubuntu gutsy 64 bit and getting online.
Not so lucky on 32 bit wifi ubuntu, so went through my
usual on that machine, checking all network managers,
hostname, resolv.conf, modules loaded, blcaccklist,
etc, and even  took out the old cantankerous WMP54G
wifi card, rebooted and reinstalled the card. Many
ifdown's and ifup's but no connection. Went over the
network managers many times and began to notice that
knetwork manager had a lo entry everytime I restarted
it instead of wlan0. Getting suspicious here so tried
to setup a localhost wifi interface but
couldn't(iwconfig said not supported even though the
64bit machine uses lo for an eth0 interface). Noticed
that I had both wlan0 and eth0 checked in the knetwork
manager(which I had before going static and it worked)
and on a hunch unchecked the eth0 iface and the
browser immediately loaded the URI. Now I know
someone, maybe Derek, is going to say you can't have 2
ifaces selected at the same time but I did and it
worked since the eth0 wasn't connected and got
Anyway, both machines are up on gutsy and have run
vista on the 64 bit one, all ok for now.  It'll be a
while before I have the courage to reboot.  IAC, if I
have trouble it will be on the ubuntu with the wifi
card in it.
Thanks Gary, for all your time and trouble spent
helping me, a network dummie slowly, gettiong
experience with setting it up. I'd still be lost
without you patience and help.  Your a good man,

Leonard Chatagnier
lenc5570 at

More information about the ubuntu-users mailing list