BIOS problem?

Neil hok.krat at
Wed Feb 20 22:08:09 UTC 2008

On Wed, Feb 20, 2008 at 10:16 PM, Karl Larsen <k5di at> wrote:
>     Using 'fdisk' I find an impossible situation. I have this hard drive
>  that is /dev/hda and that is fine. In BIOS it is the first HD in the
>  list. Way down the list is the second HD which is a SATA drive and must
>  be plugged into the proper SATA header. For some reason 'fdisk' in this
>  Ubuntu calls this HD /dev/sda!

Sata uses the scsi driver wich results in the name "sda"

>     I have mounted a partition from the SATA HD /dev/sda7 to this system
>  and copied the whole system to the SATA HD. But grub gets confused. It
>  can't seem to see the SATA HD. I can't get grub to boot the new Ubuntu
>  system.

This is probably a BIOS problem
1. There are BIOS'es who need a special setting to be able to boot from SATA.
2. It is possible SATA is swiched of entirely in the BIOS. Linux can
still adress and recognise the device, so it uses it (Linux discards
the information provided by the BIOS and does it's own system check.
This has some major advantages)
Last but not least: it could be Grub. Have you tried booting from the
Supergrub CD? ( It might help.

>  Has anyone else solved this kind of problem? It may be just a BIOS
>  problem brought on by the fact that SATA is a band aid added to the BIOS.

My Asus P4P800 didn't recognize any SATA dives straight out of the
box. I had to activate it.


There are two kinds of people:
1. People who start their arrays with 1.
1. People who start their arrays with 0.

More information about the ubuntu-users mailing list