Linksys WMP54G Wireles Adaptor Wont Work; Or I Don't Know How To

Leonard Chatagnier lenc5570 at
Sat Feb 9 17:33:25 UTC 2008

--- Christopher Copeland <chrcop at> wrote:

> Hi Leonard,
> On 8 Feb 2008, at 12:20, Leonard Chatagnier wrote:
> > If that's not right thing or you or anyone have
> suggestions, let me  
> > hear them.  And thanks for keeping the thread
> alive.

> Sorry for coming to this thread late. I have some
> experience with  
> wireless cards in linux and I'd be willing to offer
> any help I can.
Thanks Chris, I'm happy you came as there is a lot for
me to learn on wifi setup. I'll post what I've done to
now and the remaining issues for me at the bottom.

> I have a Giga-Byte GN-WP01 in a machine that has
> worked well with both  
> Gentoo and now Ubuntu. It is also a ralink rt61
> based pci card, but  
> note I don't know if the GT version is the same.
> It's using the  
> rt61pci module now but has also worked with
> ndiwrapper. What are the  
> issues you are seeing with your linksys card?
The rt61pci is the one I'm now using and was finally
able to get the light on back to burn and blink so I
know it's partly working and I think my remaining
problem is in setup.  I'll list issues at end.

> I'd recommend using a usb based adapter if you are
> going to buy  
> something new. Better reception, easier to move to
> another machine  
> (laptop) and much easier to move around with a usb
> extension than a  
> lossy cable and RP-SMA connector.

Don'r know the term unless that's the designation for
the PCI slot.

 The ralink rt73
> cards are the best  
> and my personal favourites. The D-Link WUA-1340 is
> easy to find around  
> here and hasn't been revision bumped yet so you
> don't need to worry  
> which chipset you are actually buying if you shop
> online etc..
That's good to know; rt73 and buying on line, thanks.
Ok, here's what I've done:

Added rt61pci to modules and blacklisted mac8021(which
kept the card from being recognized or getting an irq
assigned and no light burning.

lsmod list these rt* and related modules:

mac80211    4  rc80211_simple, rt61pci, rt2xx00pci,
rt61pci     0
rt2x00pci   1  rt61pci
rc80211_simple   1 rt61pci
rt2x00lib   0
rtkill      1 rt2x00lib
cfg80211   1 mac80211
input_polldev  1 rt2x00lib
crc_itu_t   1 rt2x00lib
eeprom_93cx6  1 rt61pci
(Note to newbies like me: even though mac80211 module
is listed by lsmod, the card's operating green light
didn't come on until mac80211 was added to the
/etc/modprobe.d/blacklist file.  I also shutdown,
pulled the wifi card and rebooted without card in
place after adding any module(s) to /etc/modules or
module(s) to /etc/modprobe.d/blacklist file as said in
the WMP54G v4.1 installation manual and as found by
googling for the rt* modules. Then shutdown again,
reinserted the module and rebooted. This is a

lspci -v  Last line entry said;
Capabilities: <Access Denied>   Note:An issue to me.
Is it just saying the card is not receiving or that I
don't have all the crypto crap put into the
configuration yet? This is also on the NIC and
winmodem entries which aren't connected and not

Related DMESG output:
Flash: new dmesg output since last reboot and first
attempt to use wifi config GUI tools. Made me realize
that I was using the old modem/router WEP KEY instead
of the replacement modem WEP key. Corrected in GUI

EP from??????? (Sorry, couldn't read my writing:only
sure of first 2 letters)
WEP decrypt failed    (ICV)
Wlan): RX WEP frame, decrypt

Decided to shut computer down for night and reboot in
am.  All WEP errors disappeared on reboot.  Must have
corrected WEP KEY error.

Next is the iwlwifi errors reported on the orig post.
I'll not repeat. too long.  Please refer to orig post.
I didn't post the PCI recognition and assignment
lines: LINKA, irq assignment, etc. They were correct
and immediately followed by the iwlwifi errors.

wlan: initial auth_alg=0
wlan: authernticate with AP 00:18:3f:26:4d:a9
wlan: RX authentication from 00:18:3f:26:4d:a9 (alg=0
transaction=2 status=0)
wlan: authenticated
wlan: associated with AP 00 :18:3f:26:4d:a9
wlan: RX AssocResp from AP 00 :18:3f:26:4d:a9
(capab=0x431 status=0 aid=1)

wlan: asssociated
NET: Registered family protocol 10
lo: Disabled Privacy Extensions
ADDRCONF(NETDEV_UP): eth0: Link is not ready
No IPv6 routers present
ADDRCONF(NETDEV_UP): wlan0: Link is not ready
wlan0: RX deauthentication from 00:18:3f:26:4d:a9
wlan0: deauthenticated
ADDRCONF(NETDEV_UP): wlan0: link is not ready
ADDRCONF(NETDEV_UP): wlan0: link is not ready

I'm using the KDE networking setup GUI's and iwconfig
when I can't do it with KDE GUI's. I've used
KWIFIManagerand it's configuration settings module,
Network tools and Network settings to experiment,
become familiar with and make configuration settings.
I'm not experienced, my first time to do a wifi setup
and I'm sure there are errors and wrong protocol. Here
are the issues I've come across:

Acidently set "sudo iwconfig wlan0 freq 2.437G" when
it should have been 2.437M and now cant correct it.
When I replace "G" with "M" get error:
iwconfig: command "M" is ambiguous. But since I
changed KWIFIManager settings from interface wlan0 to
autodetect the channel(6) and frequency(2.437M) are
correct as shown on the GUI popup. iwlist frequency or
cchannel both show:
0 channels
frequency 2.437 GHz(not MHz as should be)

Clicking "activate" in the manager settings interface
The following setting could not be applied
Speed setting could not be modified

The wifi manager GUI shows"

Signal strength: 0
AccessPoint: UKNOWN
Local IP: unavailable

The Configure Settings GUI show:
autodetected ipo wlan0 selected
Speed auto selected
Use encription selected(with correct WEP 64-BIT hex
key entered
Load proset configuration on startup selected
Network Name 2wire482

Network Tools has no IP info in window for wlan0
can't ping gateway

syslog shows:
ubuntu ypbind: broadcast: RPC; Timed out

That's all. More than you cared to see, I know. Your
offer to help is gratefully welcomed.

Leonard Chatagnier
lenc5570 at

More information about the ubuntu-users mailing list