X starting but then quitting on Nvidia

NoOp glgxg at sbcglobal.net
Tue Feb 5 21:16:57 UTC 2008

On 02/05/2008 05:52 AM, Karl Larsen wrote:
>     There has been a long learning curve on the Nvidia video device(s) 
> in Linux and it appears the best Linux drivers provided to us are not 
> well tested. In my case I find if there is a splash added to the kernel 
> list Nvidia will not start reliably.
>     Of late I have had to boot using the emergency kernel which has no 
> splash in the kernel line. That always works. But the normal boot up 
> fails more and more often.
>     So I deleted the splash in the main kernel and now it works fine too.
> Karl

Perhaps related to a problem that I just experienced this morning with a
T21 Thinkpad (ATI video - no Nvidia). One of the updates that I did -
perhaps the new kernel security update - created a problem whereby the
system would boot, I'd get the standard splash, then a black screen
instead of the gdm login screen. Couldn't Ctrl-Alt-F1 - nothing. Had to
reboot using recovery mode and entering gdm from there. Even tried sudo
dpkg-reconfigure -phigh xserver-xorg.

At first I thought it was a grub issue, so I tried the nosplash & then
it seemed to boot with a good gdm. Tried adding vga=733 and a few other
odds & ends, but still unreliable. I finally did a comparison the the
/etc/X11/xorg.conf file on my other 'un-updated' A21 Thinkpad and found
that the updated system's xorg.conf 'DefaultDepth' had been set to 16 vs
my standard 24. Reset DefaultDepth to 24 & no more problems.

So now I'm back to 'splash' and removed the vga= etc.

More information about the ubuntu-users mailing list