Video driver problem on upgrade to Hardy

Paolo paolo2 at
Fri Apr 25 09:00:40 UTC 2008

Good morning!
Current situation:
Managed to get back to the correct 1920x1200 resolution. But everything running
*very* slowly.

> sudo apt-get install --reinstall displayconfig-gtk
> Then if it is still not showing up:
> right click on Applications, then "Edit Menus". Go to "Other" and you
> will find it there - tick the box.

Thanks. Now I have it. But I cannot get it to change to the hardware I have. It 
crashed, so I have put in a bug:

> Xrandr was replaced by x11-server-utils.
> sudo apt-get install --reinstall x11-server-utils

This reports:

Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Couldn't find package x11-server-utils

> Make a backup of your /etc/X11/xorg.conf, and then check your
> /etc/X11/xorg.conf and change:
> Subsection  "Display"
> 		Depth  <some number>
> 		Virtual <some number> <some number>
> to
> Subsection  "Display"
> 		Depth  24
> 		Virtual 1280 1024

I already have:

Section "Screen"
	Identifier	"Default Screen"
	Device		"Configured Video Device"
	Monitor		"Generic Monitor"
	Defaultdepth	24
	SubSection "Display"
		Depth	24
		Virtual	1920	1200
		Modes		"1920x1200 at 60"	"1680x1050 at 60"	"1600x1024 at 60"	"1440x900 at 60" 
"1280x800 at 60"	"1280x720 at 60"	"1280x768 at 60"	"800x600 at 60"	"800x600 at 56"

- - -

By the way, yesterday I tried to install the Feisty file
xserver-xorg-video-ati_6.6.3-2ubuntu6_i386.deb (having uninstalled the newer 
one), but the system refused to install it, saying that it was old package.


More information about the ubuntu-users mailing list