Install problem Brother 2040 printer

miner joh_hunter at
Sat Sep 22 20:35:24 UTC 2007

After your help I did download the CUPS driver from Brother even though 
there was one installed with Ubuntu, but again had difficulty opening or 
installing it. Just shows how little knowledge or understanding I have of 
the Linux system. If I

Anyway, poking around some more I found the solution. It was so simple it 
was not even funny. I downloaded the two files again, the LPR and the CUPS 
file but this time I did not save them to the disk and they installed 
beautifully. My printer works now without problems but I will have to fine 
tune it a bit. Suggestion for downloading came from;

I have always been reluctant to do an install via the net prefering to save 
the file and then install but I may have to rely on this until I understand 
the system better.

I appreciate your help.

----- Original Message ----- 
From: "Patton Echols" <p.echols at>
To: "Ubuntu user technical support, not for general discussions" 
<ubuntu-users at>
Sent: Saturday, September 22, 2007 12:41 AM
Subject: Re: Install problem Brother 2040 printer

> On 09/21/2007 07:57 PM, miner wrote:
>> I am following instructions from the Brother website for the 2040
>> printer and I believe it is installed
>> as G Debi Package Installer detects the installation recognizing the
>> Brother 2040 LPR driver. However the computer does not detect the 
>> printer.
> Well, I am certainly no expert, but I started poking around since I have
> a couple of brother printers that don't work quite right.
> I think that the CUPS printing system is installed by default, in
> Ubuntu, not LPR.  If that is right, then you may need to install a cups
> wrapper driver after having installed the LPR driver.  Read here:
>> Once installed the instructions for USB users state;
>> *Ensure that the :lp line reads as follows; :lp=usb/lp0*
>> Where do I find this :lp line?
> Umm, where did you find this instruction?  It is very unusual to find an
> instruction that does not, at some point tell what file you are looking
> for.
>> At the end I am supposed to enter; */etc/init.dlpd restart* but the
>> command is not recognized.
> That is going to be " /etc/init.d/lpd restart"  note the missing slash
> mark.  But if you do not have an LPR type printer system installed (ie:
> you have CUPS) then I don't think it will work anyway.  I looked in my
> ?etc/init.d/ directory and there is no file "lpd".  However I do have a
> file "cupsys" which is a script to stop, start, restart or get the
> status of the cups system.  My guess is that's what you have too.
> If I'm right, then I think you are half way there.  Now that you have
> the LPR driver installed, you install the CUPS wrapper for your 2040,
> then probably restart CUPS using this command:  /etc/init.d/cupsys restart
> But PLEASE note, this is an educated guess.  I have not tried it myself
> yet.  Read that brother page and note that they have a link for help on
> the page too.
> Post back and let us kn ow how it goes.
>> Any help greatly appreciated.
> -- 
> ubuntu-users mailing list
> ubuntu-users at
> Modify settings or unsubscribe at: 
> -- 
> No virus found in this incoming message.
> Checked by AVG Free Edition.
> Version: 7.5.488 / Virus Database: 269.13.28/1021 - Release Date: 
> 21/09/2007 2:02 PM

More information about the ubuntu-users mailing list