Upgrade to 7.10 halts bootup

Ken McLennan kenrmcl at mysoul.com.au
Tue Nov 27 07:36:12 UTC 2007

G'day there One & All,

    Based on the stability and ease of use of 7.04, I just clicked the 
magic "Upgrade" button and after a while 7.10 appeared on my hard drive. 
I now find that it hangs on loading and a search of the fora has found 
several proposed remedies but none that have worked. Hence I'm now here 
requesting assistance.

    I have an ASUS Pro31P notebook with a Centrino Duo processor. As 
mentioned above I had 7.04 running just fine from its GRUB entry. I have 
Vista, Elive, and Ubuntu in a triple boot setup. Ubuntu has / on 
/dev/sda7, with /boot on /dev/sda6. Elive is on /dev/sda5 and I use 
Elive's graphical variant of GRUB to boot it all. This worked fine with 

    Now it begins to boot but hangs at the line "drivers 
/usb/input/hid-core.c: v2.6: USB HID core driver". After about 10 
minutes it drops to a shell in the initial ramfs and displays:

    check root = bootarg cat /proc/cmdline
    or missing modules, devices: cat /proc/modules ls /dev
    ALERT. /dev/sda7 does not exist. Dropping to shell!!

    I assume that the latter indicates the boot process has stopped 
before mounting the Ubuntu / partition.

    Google has given me suggestions to try variants of "no-apci", 
"acpi=off", "noapic", and "nolapic". None of these alone, nor any 
combination has worked. Neither did all of them together (which didn't 
really surprise me). I'm now stumped and asking for any ideas you may 
have overcome the hassle.

    I'm not sure what filesystem I've used for '/boot' but it's either 
reiserfs like '/' is, or ext3. In either case, it shouldn't cause any 

Thanks for listening,
Ken McLennan
Qld, Australia

More information about the ubuntu-users mailing list