Linux printer share quit working

Linda Hanigan haniganwork at
Mon Nov 26 05:15:19 UTC 2007

Did you get your printer working? I had a similar problem with a samba
printer a little over a month ago. I could see the printer from the
windows XP box but it refused to print. I tried fixing it from the Linux
side but it did not work. Then I tried fixing it from the windows side.
First I tried reinstalling the smb printer it did not work. Then I set
it up as a cups printer instead of as a samba printer in windows. Here
is what I did that worked
Windows Client setup
      * Click Start/Settings/Printers and Faxes. 
      * Click "Add a Printer". 
      * Click Next. 
      * Select "Add a network printer ..." and click the Next button. 
      * Select "Connect to a printer on the Internet..." and type in the
        URL for the print queue. It will look like
        http://server_IP:631/printers/PrinterName (the PrinterName is
        the same from the localhost:631 entry of your printer). Then
        click the Next button. 
      * In the next windows select your printer model. have driver
        choose the one on CD English/Drivers/WindowsXP/1320.PS and
      * Click Finsh
I wondered if a Windows update broke the setup as I had not made any
changes recently to the Linux box. Anyway hope this helps if you haven't
solved your problem yourself by now.

On Wed, 2007-11-21 at 08:44 -0500, Alex Janssen wrote:
> One more note on this ...
> If I connect this printer to a Windows XP box,  I can print to it using 
> the same commands on the SCO box, just by changing the server name in 
> the device line.
> I'm going to look in the cups error_log more extensively soon as I get 
> to work today.  If I find something, I'll post it in case it helps 
> someone else.
> Alex
> -- 
>  Doesn't expecting the unexpected make the unexpected become the expected? - Meso Happy (181)

More information about the ubuntu-users mailing list