7.04: X11 remote display problem

bill purvis bil at beeb.net
Fri Nov 23 19:21:45 GMT 2007


On Friday 23 November 2007, Joachim Schrod wrote:
> bill purvis wrote:
> > I'm still having no joy with getting anything to open a remote X11
> > window on my laptop since I changed to Ubuntu from Mandrake.
> >
> > I'm using ssh to log in to my server (and yes I've tried using ssh -X
> > but that makes no difference). Once I'm logged in I try to start an
> > emacs window on the laptop:
> >
> > server$ echo $DISPLAY
> > felix:0.0
>
> Something in your profile sets $DISPLAY; this is *not* the DISPLAY
> tunnel from ssh. ssh starts to use displays 10 and following on the
> local host; i.e., $DISPLAY should be localhost:10.0 or similar.
>
At last ! I used to set DISPLAY in my .bashrc on the server.
Always worked for me in the past. Removing that solved the
problem.

Many thanks - I knew someone would come up with the solution....

Bill
-- 
+---------------------------------------+
| Bill Purvis, Amateur Mathematician    |
|  email: bil at beeb.net                  |
|  http://bil.members.beeb.net          |
+---------------------------------------+




More information about the ubuntu-users mailing list