FQDN Misery Re: To: Postfix, Mutt And No Root Mail? & amavisd-new Install

NoOp glgxg at sbcglobal.net
Fri Nov 9 00:08:07 GMT 2007


On 11/08/2007 03:22 PM, Leonard Chatagnier wrote:

> Also, I have no thoughts/plans ever to host an
> internet site, etc, etc, and see no need for a free
> domain name. This would be more complications, I don't
> need. I just want root mail and mail from the
> system/network sent to root to be sent to me as I'm
> root and sole operator. Don't remember the program
> names but I'm sure you know what I mean. When I ran
> Debian, I got so much of it I uninstalled some of it. 
> It just worked then but I believe exim4 was used ipo
> postfix.
> Your comments and assistance is most appreciated.  As
> mentioned to David, Feisty, IMHO, should have set up
> these mail programs better. A linux novice just can't
> do it without lots of help.  Thanks again,
> 
> Leonard Chatagnier
> lenc5570 at sbcglobal.net
> 

If you recall, in another thread I'd mentioned that I had root mail that
had been sent by rkhunter. Well I found a copy on the backup system, and
it uses on root@<systemname>:

> From root at gg2xp Mon Sep 10 08:07:30 2007
> Return-path: <root at gg2xp>
> Envelope-to: root at gg2xp
> Delivery-date: Mon, 10 Sep 2007 08:07:30 -0700
> Received: from root by gg2xp with local (Exim 4.63)
> 	(envelope-from <root at gg2xp>)
> 	id 1IUkrH-0006E3-Lw
> 	for root at gg2xp; Mon, 10 Sep 2007 08:07:27 -0700
> Subject: [rkhunter] Daily run
> Message-Id: <E1IUkrH-0006E3-Lw at gg2xp>
> From: root <root at gg2xp>
> Date: Mon, 10 Sep 2007 08:07:27 -0700

Note that rkhunter uses Exim & it requires no actual FQDN, but uses the
systemname instead. Were I to reinstall rkhunter, I'd find that it
installs the following:

$ sudo apt-get install rkhunter
[sudo] password for gg:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  exim4 exim4-base exim4-config exim4-daemon-light libdb4.3
Suggested packages:
  eximon4 exim4-doc-html exim4-doc-info libmail-spf-query-perl
Recommended packages:
  mailx libmd5-perl
The following NEW packages will be installed:
  exim4 exim4-base exim4-config exim4-daemon-light libdb4.3 rkhunter
0 upgraded, 6 newly installed, 0 to remove and 0 not upgraded.
Need to get 2293kB of archives.

That's it. So, perhaps you might want to explore exim instead? I
honestly don't know as I've never used postfix or exim.





More information about the ubuntu-users mailing list