Feisty wireless with orinoco

Bruce Badger bwbadger at gmail.com
Mon May 28 12:11:54 UTC 2007

The latest progress getting Feisty to work with the Orinoco WiFi card
on my T21 is ... none :-(

I have just tried the Mepis 6.0 live DVD and this works fine, as does
Knoppix.  Only Ubuntu seems to exhibit this problem (as below).

I would appreciate any hints or tips.

Many thanks,

On 26/04/07, Bruce Badger <bwbadger at gmail.com> wrote:
> Hi,
> I have just installed Feisty on a Thinkpad T21 that was running sarge.
>  I am having a problem getting Feisty to use my trusty orinoco
> wireless card.  I have worked through the troubleshooting guide here:
>  https://help.ubuntu.com/community/WifiDocs/WirelessTroubleShootingGuide
> ... but to no avail :-(
> Here´s what I see:
> lshw shows the following (which looks fine to me):
> *-network
>        description: Wireless interface
>        physical id: 1
>        logical name: eth1
>        serial: 00:02:2d:66:7e:9c
>        capabilities: ethernet physical wireless
>        configuration: broadcast=yes driver=orinoco driverversion=0.15
> firmware=Lucent/Agere 7.28 link=no multicast=yes wireless=IEEE 802.11b
> pccardctl ident (looks good too):
> Socket 0:
>   product info: "Avaya Communication", "Avaya Wireless PC Card",
> "Version 01.01", ""
>   manfid: 0x0156, 0x0002
>   function: 6 (network)
> iwconfig (again, just what I would expect for this network which uses
> a very crude hidden ssid & MAC address filter and no encryption):
> eth1      IEEE 802.11b  ESSID:"setnet"  Nickname:"alice"
>           Mode:Managed  Frequency:2.437 GHz  Access Point: 00:18:39:8A:68:73
>           Bit Rate:2 Mb/s   Sensitivity:1/3
>           Retry limit:4   RTS thr:off   Fragment thr:off
>           Encryption key:off
>           Power Management:off
>           Link Quality=42/92  Signal level=-52 dBm  Noise level=-94 dBm
>           Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
>           Tx excessive retries:0  Invalid misc:0   Missed beacon:0
> Even wavemon shows everything working just as I would expect.
> BUT when I try to start the network I get this:
> DHCPDISCOVER on eth1 to port 67 interval 6
> DHCPDISCOVER on eth1 to port 67 interval 14
> DHCPDISCOVER on eth1 to port 67 interval 11
> No DHCPOFFERS received.
> If I use a static IP config it appears to be applied (or so says
> wavemon) but I can´t ping anything.  I get ¨no route to host¨.
> It is as if there is a disconnect between the orinoco hardware+drivers
> (which all look good) and the Linux socket stuff (which seems to be
> unable to connect to the orinoco stuff).
> Can anyone please point me to documentation I missed or perhaps give
> me some tips?
> Many thanks,
>     Bruce

Make the most of your skills - with OpenSkills

More information about the ubuntu-users mailing list