[Feisty - resolution] gthumb not autostarting w/digital USB camera

NoOp glgxg at mfire.com
Sun May 27 21:02:57 UTC 2007

After upgrading my son's computer from Dapper ==> Edgy ==> Feisty my son
tried connecting his Canon A75 PowerShot digital camera today to
download photos from the camera. Previously in Dapper all he had to do
was plug the camera into the USB port and gThumb would automatically pop
up and ask if he wanted to download the photos from the camera. Didn't
work in Fiesty.

So, the first thing that I did was check System|Preferences|Removable
Drives and Media|Cameras to make sure that 'Import digital photographs
when connected' as checked (it was) and that the command
'gnome-volume-manager-gthumb %h' was in the command line (it was).
I could, however, manually load gThumb from the Applications menu and
instruct it to import (File|Import Photos) - that worked.

Got to hunting around for libgphoto2 & gThumb bugs and ran across this
one: https://bugs.launchpad.net/ubuntu/+source/libgphoto2/+bug/91250
In that bug report is a post by HarmonicaGoldfish (2007-05-04) that says:

All through Edgy I did not get the pop-up for importing the photos, and
this continued with my upgrade to Fesity.

Phogy, on the ubuntu forums suggested this:

rm -rf ~/.gconf/desktop/gnome/volume_manager

I did it, restarted, and it now works like a charm.

I also did it, restarted, and can confirm that this fixed the problem.
Did it on my other Feisty systems that also had been upgraded from
Dapper/Edgy/Feisy and the camera is now immediately detected, gThumb
starts automatically & all is well again.

Apparently the values in the /.gconf/desktop/gnome/volume_manager files
do not get deleted during the upgrade and create a conflict that does
not allow gThumb to autostart.

Just thought I'd pass that along in case anyone else runs across the
same problem.

More information about the ubuntu-users mailing list