sktsee sktsee at
Sat May 19 14:29:14 UTC 2007

On Fri, 2007-05-18 at 18:19 -0700, NoOp wrote:
> Anyone else have a working internal modem? Please add your *internal*
> modem and let's see if we can offer some sound advise with regards to
> _working_ modems vs do an ebay or google search. Here is a sample of
> three system that are not working:
> System|Preferences|Hardare Information
> Internal Modem		Ubuntu OS	Works	Computer
> Agere Systems Wildwire	6.x - 7.04	no 	[1]
> Agere V90 Wildwire	6.x - 7.04	no 	[2]
> SIS AC'97 		6.x - 7.04	no 	[3]
> 1. Built into a Compaq Presario 5670
> 2. Built into a IBM ThinkPad A21M
> 3. Built into a Sony Vaio Desktop
> Note: I have another test system that has a 3rd party modem in
> (non-winmodem) but it's being updated now so I'll need to try later. I
> also have an old Fremont Frecom Fax596 that I dug up out of a box that
> I'll try as well -- anyone get one of these to work?
I've got a Smart Modular Technologies 90109-2 (OEM'd for HP Pavilion
7955) 56K Data+Fax LT Modem that's worked with every distribution of
linux I've tried (SUSE, Mandriva), and every version of Ubuntu I've used
(Breezy, Dapper, and now Feisty). It uses the Agere DSP1648c-TV3 (Mars
3.2) chipset and before Feisty, used to run just fine using the ltmodem
driver on -386 kernels. On Feisty, however, using the ltmodem driver
with the -386 kernel causes a kernel panic which never happened with
Breezy or Dapper. The problem seems to be associated with some sort of
conflict with the modem and my pc's USB controller. Anyway, in order to
get my modem to work, I've had switch back to the generic kernel and use
the latest martian drivers located at the linmodem site:

So far it works, but it seems the performance isn't as good as what the
ltmodem driver produced. Oh well, at least it's working. 


More information about the ubuntu-users mailing list