Pidgim (Gaim 2.0) issue

sktsee sktsee at
Mon May 14 17:11:27 UTC 2007

On Sun, 13 May 2007 22:38:34 +0200, Mauro Grauso wrote:

> Ah great. that's the piece of information I was after. Now, I'm just
> curious, where did you find it? I mean it's not documented and there's
> no forum or active mailing list for Pidgin. Have you looked at the
> sources? It's the only thing I didn't look because of lack of time.
> thanks.
> Mauro

Yeah, it took a bit of sleuthing to figure out what was needed by the
configure script to enable compile support for the idle time detection.
Basically, I started with the "configure --help" output,  which said in
the description for the "--disable-screensaver" option that the
xscreensaver extension was used to detect idleness. So I did a recursive
grep for any mention of xscreensaver in any files in the directory (grep
-irl xscreensaver *). That came up with nine files, two of which had
"idle" in their filenames (libpurple/idle.c and pidgin/gtkidle.c).
Figuring that gtkidle.c was the best bet to find what I need, I opened it
and found the reference to the header file <X11/extensions/scrnsaver.h>. I
didn't have this header file on my system, so I ran a search using
apt-file (apt-file search scrnsaver.h). It came back with
x11proto-scrnsaver-dev package as the result. Installed that package and
re-ran ./configure. It still wouldn't enable the xscreensaver extension,
so I delved into the config.log file to see what errors, if any, were
being produced.

Wading through config.log I found the section where the configure script
tested for the "XScreenSaverRegister" function and why the test was
failing. It tests two libraries, libXext (-lXext) and libXss (-lXss), to
see if either has that function. Apparently, if the configure script finds
this function in either of those libraries, then the neccessary
requirement to enable the xscreensaver extension compile option is met. So
I checked to see if I had the dev packages for libXext and libXss
installed on my system. I already had libxext-dev installed but not
libxss-dev. So, I installed libxss-dev and re-ran ./configure and it
finally worked!


More information about the ubuntu-users mailing list