[Feisty] Normal ways to kill xserver don't work

Ari Torhamo ari.torhamo at saunalahti.fi
Tue Mar 20 17:27:53 UTC 2007

ma, 2007-03-19 kello 20:44 -0700, John L Fjellstad kirjoitti:
> Ari Torhamo <ari.torhamo at saunalahti.fi> writes:
> > Sorry for taking so long to answer, but after I installed Nvidia
> > 1.0-9755 driver my system wouldn't boot anymore (the driver worked
> > until the first reboot). I got an error message about some
> > incompatible kernel modules. Trying to boot with the previous kernel
> > version didn't help.
> are you using the Nvidia drivers from Ubuntu or Nvidia?  That is, are
> you compiling the drivers yourself?  

The driver is from Nvidia - I didn't even know that Ubuntu provides the
1.0-9755 driver. I didn't compile the driver though, the installation
program took care of that.

> if you are, do you have the linux-headers installed?

Yes I do (I mean did - I already re-installed Feisty because my system
started to hang on every boot). It seems that linux-headers are a part
of the default installation, because I have them on my two days old
Feisty installation ("Generic Linux kernel headers - This package will
always depend on the latest generic kernel headers available")

> It's been awhile since I needed to compile the Nvidia drivers myself.
> You do realize the drivers need both kernel modules and X drivers?  

What exactly are the packages you refer to with kernel modules and X
drivers? You see, I don't know much about these things. I'm at my best
when I'm told exactly (by the package name) what to install or
remove :-) This is what's needed according to Nvidia web site

"If you wish to install the NVIDIA Linux graphics driver on a Debian
GNU/Linux or Ubuntu system that ships with Xorg 7.x, please ensure that
your system meets the following requirements:
        * development tools like make and gcc are installed
        * the linux-headers package matching the installed Linux kernel
        is installed
        * the pkg-config and xserver-xorg-dev packages are installed
        * the nvidia-glx package has been uninstalled with the --purge
        option and the file /etc/init.d/nvidia-glx does not exist.
If you use Ubuntu, please also ensure that the linux-restricted-modules
packages have been uninstalled. Alternatively, you can edit
the /etc/default/linux-restricted-modules
or /etc/default/linux-restricted-modules-common configuration file and
disable the NVIDIA linux-restricted kernel modules (nvidia,
nvidia_legacy) via:

The installation program seemed to either install everything that was
needed, or tell what packages are needed for installation to proceed. I
already tried Nvidia installer with my previous graphics card (GeForce
7900 GTO) and it worked without problems then.

Thanks for your input

Ari Torhamo

More information about the ubuntu-users mailing list