Upgrade to Edgy failing on X11R6 error

Dave M G martin at autotelic.com
Tue Jan 16 22:09:48 UTC 2007

Ubuntu Users,

For various reasons, I wanted to upgrade from Dapper to Edgy. According 
to this official site:


... Edgy Eft is the "current stable version". So I felt confident that 
this should be a safe move.

I used this method to do the upgrade:

gksu "update-manager -c"

Despite my fibre-optic connection, it was going to take all night to 
download, so I left it until this morning.

When I woke up, I found it had encountered an error:

dpkg: error processing 
/var/cache/apt/archives/x11-common_1%3a7.1.1ubuntu6.2_i386.deb (--unpack):
trying to overwrite `/usr/X11R6/bin', which is also in package kinput2-wnn
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

This page which has a list of common problems:

... It did not list my situation exactly. Two people with similar 
problems had either Opera or ATI graphics cards. I don't have opera, and 
my graphics card is Nvidia.

So then I tried manually clearing out the /usr/X11R6/bin directory, and 
running the update again. Same error. I tried deleting the offending 
directory altogether. Same error.

I tried running the update manager again, and this time it said:

"It is impossible to install or remove any software. Please use the 
package manager "Synaptic" or run "sudo apt-get install -f" in a 
terminal to fix this issue at first."

So I ran that command:

sudo apt-get install -f

And it returns the same error.

Another web site recommended running the following:

$ sudo dpkg-reconfigure xserver-xorg

But that got me this error:

/usr/sbin/dpkg-reconfigure: xserver-xorg is broken or not fully installed

So, now the current status is that not only do I not have Edgy 
installed. I can't upgrade or install anything with apt-get or Synaptic 
because they always halt on an error that I have to fix my broken 
packages. But neither Synaptic or apt-get will permit me to fix them 
because of complaints about Xorg related packages.

How do I get out of this loop, and either get my system back to being 
stable, or succeed in upgrading to Edgy?

Dave M G
Ubuntu 6.06 LTS
Pentium D Dual Core Processor
PHP 5, MySQL 5, Apache 2

More information about the ubuntu-users mailing list