Upgrade to Edgy failing on X11R6 error

James Gray james at gray.net.au
Wed Jan 17 00:33:42 UTC 2007


On 17/01/2007, at 9:09 AM, Dave M G wrote:

> Ubuntu Users,
>
> For various reasons, I wanted to upgrade from Dapper to Edgy.  
> According
> to this official site:
>
> https://help.ubuntu.com/community/EdgyUpgrades
>
> ... Edgy Eft is the "current stable version". So I felt confident that
> this should be a safe move.

No idea.  I did a fresh install of Edgy (due to a completely new  
machine), but previously I've upgraded from previous-stable ->  
current-stable with only a few minor glitches (shameless plug: http:// 
gray.net.au/article.php?story=20051016111619198).  That article on my  
blog has some hints about how you can get around the problems you are  
having.

> I used this method to do the upgrade:
>
> gksu "update-manager -c"

I'm not a big fan of upgrading the X server and associated libraries  
while it's still running.  I usually drop to a command prompt and do  
the upgrades there:
1. Log out of Gnome/KDE/whatever.
2. Switch to a console (CTRL-ALT-F1) and log in.
3. Shutdown the X server:
    sudo /etc/init.d/gdm stop
    Replace "gdm" with "kdm" on Kubuntu, or in other cases "xdm"
4. Replace all instances of "Dapper" with "Edgy" in /etc/apt/ 
source.list:
    sudo vi /etc/apt/sources.list
    (If you prefer a different editor, then that's fine too)
5. Finally, run the update:
    sudo apt-get update
    sudo apt-get -u dist-upgrade

If there are any problems, fix them before rebooting.  Yes, a reboot  
is necessary, when moving up to the latest stable version, because it  
invariably involves a kernel upgrade too.

> Despite my fibre-optic connection, it was going to take all night to
> download, so I left it until this morning.

The speed of your connection is only as fast as the slowest link  
between you and the destination.  Maybe you need to find a mirror  
that your ISP peers with or something?  I have a 12Mbps synchronous  
link but rarely see more than about 2-3Mbps effective bandwidth due  
to slower upstream pipes.  YMMV.

> dpkg: error processing
> /var/cache/apt/archives/x11-common_1%3a7.1.1ubuntu6.2_i386.deb (-- 
> unpack):
> trying to overwrite `/usr/X11R6/bin', which is also in package  
> kinput2-wnn
> Errors were encountered while processing:
> /var/cache/apt/archives/x11-common_1%3a7.1.1ubuntu6.2_i386.deb
> E: Sub-process /usr/bin/dpkg returned an error code (1)

Ok.  Looks like kinput2-wnn has a slightly odd dependancy setup.   
There are two options here:
1. remove kinput2-wnn and try the upgrade again, then re-install  
kinput2-wnn at the end
2. force x11-common to over-write stuff when it's installing.

If you opt for #2:
sudo dpkg -i  --force-overwrite /var/cache/apt/archives/x11-common_1% 
3a7.1.1ubuntu6.2_i386.deb
then
sudo apt-get -f install
then
sudo apt-get -u dist-upgrade

> This page which has a list of common problems:
> http://www.debianadmin.com/ubuntu-edgy-upgrade-common-problems-with- 
> solutions.html
>
> ... It did not list my situation exactly.

Agreed.

> So then I tried manually clearing out the /usr/X11R6/bin directory,  
> and
> running the update again. Same error. I tried deleting the offending
> directory altogether. Same error.

Erm - don't do that.  Why have a package management system if you're  
going to run around blowing away managed files on your own?  Here's  
the problem.  Ubuntu (dpkg actually) knows what package installed  
what files.  The error you're getting isn't because of what's on the  
disk, it's because of what's in the package database.  You could  
completely "rm -rf /usr/X11R6" and you'd STILL get the error during  
the upgrade!  BTW - DON'T run that "rm -rf..."!!

> I tried running the update manager again, and this time it said:
>
> "It is impossible to install or remove any software. Please use the
> package manager "Synaptic" or run "sudo apt-get install -f" in a
> terminal to fix this issue at first."

Yep - dpkg is confused.  The "-f" means "Fix; attempt  to  correct a  
system with broken dependencies in place.".  Read "man apt-get" for  
the full story.

> So I ran that command:
>
> sudo apt-get install -f
>
> And it returns the same error.

Erm, not good.

> Another web site recommended running the following:
>
> $ sudo dpkg-reconfigure xserver-xorg
>
> But that got me this error:
>
> /usr/sbin/dpkg-reconfigure: xserver-xorg is broken or not fully  
> installed

Um yeh - YOU broke it.  See my previous comments about removing  
managed files.

> So, now the current status is that not only do I not have Edgy
> installed. I can't upgrade or install anything with apt-get or  
> Synaptic
> because they always halt on an error that I have to fix my broken
> packages. But neither Synaptic or apt-get will permit me to fix them
> because of complaints about Xorg related packages.

Try and to a "dpkg -i --force-overwrite" as described earlier.  If  
that fails, then try to do a "apt-get --reinstall x11-common" - you  
may need to add "--force-overwrite" to that as well.

> How do I get out of this loop, and either get my system back to being
> stable, or succeed in upgrading to Edgy?

I wouldn't recommend trying to roll-back to Dapper.  Instead, I'd try  
to remove that kinput2-wnn package and try the upgrade again.  Then  
if you really need special Japanese character handling (that's what  
kinput2-wnn does) then install it at the end.

Cheers,

James
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 2417 bytes
Desc: not available
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20070117/e2704331/attachment.bin>


More information about the ubuntu-users mailing list