Vote for new Ubuntu Feature---Let's try it again

Rutger van Haasteren rvhaasteren at
Tue Jan 9 09:26:08 UTC 2007

The message "Administrative rights are required to..." is a GUI version of
sudo called gksu. Try to type "gksu gedit" at the command. Works the same as
sudo. It is just that the programs that you are trying to start through the
menu are administrative programs and are called with gksu automatically.

But it is not inconsistent at all. If you were observant, then you would
have noticed a 'read only' message on the screen of your editor (I presume
gedit, so its in the title bar). This is because you must start the program
(in this case gedit) with administrative rights to edit administrative
files. So you /always/ have to use sudo or gksu to perform administrative
tasks. No exception. In my opinion this /is/ consistent.

You are right that for the Ubuntu newbie it is confusing. This is one of the
things that are part of the Ubuntu learning curve when one is used to
windows. But this learning curve isn't that big anymore for everyday work
and it is well worth it...


On 1/9/07, mtyoung <tuxman at> wrote:
>  I guess I wasn't very clear in the way I worded it the first time.
> I am the owner of this Ubuntu machine. It's a personal computer, and not a
> business desktop.
> So, if Ubuntu wants to make me think twice before it allows me to change
> something, then let it give me a warning message and ask for my root
> password; instead of making me do research, ask questions on a forum, and
> take a circuitous route in order to change what was already right in front
> of me.
> Ubuntu already does this, in some places. For instance, when you use
> Applications>Add/Remove Programs, it displays the following message when you
> try to apply a change.
> *"Administrative rights are required to..."* and then it allows you to
> enter your root password and continue.
> Yet if I've opened  /boot/grub/menu.lst, figured out what I want to
> change, then tried to save (save as actually) the changes, it tells me
> this...
> *"Could not save the file /boot/grub/menu.lst.
> You do not have the permissions necessary to save the file. Please, check
> that you typed the location correctly and try again."*
> ...when it could just as easily given me the former response.
> Ubuntu seems to be inconsistent in the way that it allows/forces you to
> accomplish system tasks. Hopefully, if enough of you agree, we can get the
> former method extended to as many functions as possible.
> Thanks for your time,
> MTYoung
> PS: read the post...
> "Change Permissions on a new hard drive to allow write...Problem Solved"
> ...if you want an easy way to get around these type of problems.
> --
> ubuntu-users mailing list
> ubuntu-users at
> Modify settings or unsubscribe at:
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list