No menu response in XCircuit

Dave M DaveM at Mich.Com
Mon Jan 8 20:13:48 UTC 2007

I have been using the X-Circuit (v3.4.21-0ubuntu1 from the 
Electronics-universe repository) schematic capture program successfully for 
the past few months. Today I rebooted my system (Ubuntu v6.06) and now the 
menus in X-Circuit no longer work.

I can use the keyboard and mouse. Everything else that I tried works. But 
when I click on any of the pull-down menus at the top (File, Edit, Text, 
Options etc), they darken when the cursor is placed over the menu box but 
the menus do not pull down when I click.

The icons in the tool bar (line, box, text, help etc.) work. The dismiss 
button in the help dialog works, the buttons in the File-Write dialog work.

I have not installed anything new since last using X-Circuit. I was using 
it and all was well just before I re-booted. I tried re-installing 
X-Circuit using Synaptic and no change. Same problem.

So I am totally baffled and not even sure how to start troubleshooting this 

Suggestions anyone....

Dave M
Davem (at) Mich (dot) Com
Ann Arbor, Mich. USA

Inter-networked computers give you freedom.
The "Trusted Computing Platform" could take that freedom away.

More information about the ubuntu-users mailing list