Postfix and aliases

John Mark Walker johnmark at
Mon Jan 8 19:46:38 UTC 2007

Are you sure your /etc/aliases.db and /etc/aliases files have the same data?

"ls -l /etc/aliases*"

I know you ran newaliases, but it doesn't hurt to make sure the
changes "took". Look at the date stamp on those files.

Also, instead of grepping for "aliases" try grepping for just "alias"
and see what "allow_mail_to_commands" and "allow_mail_to_files" are
set to.

And finally, if you don't include the "-r <mail address>" in your mail
command, does it still not work? Have you tried other methods of
sending mail to your alias address? It's been awhile since I really
looked into the "mail" command, so I can't recall what "-r" means -


On 1/8/07, Gary Hodges <fsunoles at> wrote:
> Kubuntu 6.10 AMD64
> I have the following in /etc/aliases
> testalias:      valid.address at
> If I issue the command:
> <nail -s "subject" -r valid.address at testalias>
> and then send the mail it bounces on recipient testalias at
> The following works:
> <nail -s "subject" valid.address at>
> I've run "sudo newaliases"
> >sudo postconf -d | grep aliases
> alias_database = hash:/etc/aliases
> alias_maps = hash:/etc/aliases, nis:mail.aliases
> newaliases_path = /usr/bin/newaliases
> --
> ubuntu-users mailing list
> ubuntu-users at
> Modify settings or unsubscribe at:

More information about the ubuntu-users mailing list