ati/fglrx problem

David Vincent dvincent at
Tue Aug 28 02:52:59 UTC 2007

Hi List.

I'm trying to go back to using the proprietary ati fglrx driver instead 
of the radeon one and i'm having a devil of a time with it.

i had it all working at one time and i have a backed up copy of my 
xorg.conf from that time but i can't get the driver to load properly 
anymore...that is unless i run fglrxinfo as root...which is weird.

google earth does not work when i run it (due to no direct rendering 
support) but it does when i run it as root!  check out this output:

first as me:

dvincent at dolph:~$ fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project:
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (1.5 Mesa 6.5.2)

then i did a sudo -i to become root...

root at dolph:~# fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: ATI Technologies Inc.
OpenGL renderer string: RADEON X300/X550/X1050 Series
OpenGL version string: 2.0.6334 (8.34.8)

back as me here is some lines from the xorg log...

dvincent at dolph:~$ less /var/log/Xorg.0.log | grep EE
         (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(II) Loading extension MIT-SCREEN-SAVER
(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed 
(/usr/lib/dri/ undefined symbol: 
(EE) AIGLX: reverting to software rendering
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom
(EE) xf86OpenSerial: Cannot open device /dev/wacom

...and lsmod output:

dvincent at dolph:~$ lsmod | grep fglrx
fglrx                 540004  11
agpgart                35400  2 fglrx,intel_agp

...note the fglrx driver is being loaded.

wtf is going on?  i must have a bad library or env variable in my profile??

i used this howto to get beryl working with aiglx and the radeon driver 
after i had fglrx working originally...

i've also been here:

and here:

and here:

among others looking for the solution.  envy was no help.  i'll never 
touch automatix2 again (it never touched this install) nor has 
easyubuntu.  i'm about to try a manual install of the ati driver but i i 
don't think that will help as envy already did it and root seems to be 
able to use the fglrx driver so wth is going on?


More information about the ubuntu-users mailing list