setting up beryl

David Vincent dvincent at sleepdeprived.ca
Mon Aug 13 15:51:16 BST 2007


Rutger van Haasteren wrote:
 > Hi CJ,
 >
 > You should run it with XGL, not with AIGLX. AIGLX does /not/ work ok
 > with ATI cards. The ati drivers do not support glx_texture_from_pixmap.
 > I had the exact same card (and it sucks imho). At least, I don't think
 > ATI has updated their drivers to support this in the past few months.

Hi CJ.

Rutger is right, the fglrx drivers suck with Beryl.  Switch to the 
open-source radeon drivers and you'll have better (more stable) results. 
  (Google is your friend!)

 >     it also tells me that there is no composit extension. yet i have
 >     libxcomposite1 downloaded and installed

That said the composite error you see can usually be solved by adding:

Section "Extensions"
     Option         "Composite" "Enable"
EndSection

...to the end of your /etc/X11/xorg.conf file.

You might want to join the #beryl channel on irc.freenode.com for better 
beryl support too.

Are you using Beryl from SVN?  Or from the Feisty repos?  Or some other 
custom repo you've added?

-d






More information about the ubuntu-users mailing list