Dell Optiplex 745 - Broadcom 5754 NIC

Chris Malton chrism at
Wed Aug 8 18:04:20 UTC 2007

The Alternate CD does have better hardware support, but that's about all.

I find this odd because the PCI ID of the device is listed in the pci 

Please could you send the output of
    lspci -n

This will allow us to check if your hardware is listed.



ubuntu at wrote:
> Chris,
> I heard back from my end user about the suggestions you mentioned 
> regarding the Broadcom 5754 NIC, below is his response. Any suggestions 
> you could offer would be greatly appreciated.
> I ran these commands....
> sudo modprobe tg3
> doesn't choke, but ifconfig doesn't change - eth0 does not appear. And
> ifconfig eth0
> says device not found.
> This is very strange, as tg3.ko is where you said it is, and seems to be 
> ok, in that in loading it, nothing bad happens.
> I also added it at the end of the /etc/modules file to see if rebooting 
> would do it.  Nope.
> one more thing: I'm currently running 7.04 Feisty Fawn Alternate, hoping 
> that that version would have more drivers.  I can re-install regular 
> Feisty Fawn 7.04 if that would help.
> Chris Malton wrote:
>> Hi,
>>     According to the modules listings, the Feisty (7.04) version ought 
>> to work.
>> If you manually type " sudo modprobe tg3" <enter> on Feisty in a 
>> Terminal window, followed by "ifconfig" <enter> you should get the 
>> device loaded.
>> To load it every time, you need to add it to the end of the file 
>> "/etc/modules". Don't forget that the last line of "/etc/modules" must 
>> be blank!
>> If you have no success manually loading the tg3 driver, let us know and 
>> we'll try to help you get it working.
>> Chris
>> ubuntu at wrote:
>>> Hello all,
>>> I am trying to help someone here get Kubuntu (6.06.1 or 7.04) working 
>>> with the builtin broadcom NIC inside a new Dell Optiplex 745. When we 
>>> run lspci it shows it as
>>> 0000:03:00.0 Ethernet controller: Broadcom Corporation: Unknown device 
>>> 167a (rev 02)
>>> I noticed underneath /lib/modules/kernel/.../.../net there already 
>>> existed a tg3.ko driver (that wasn't getting loaded). I tried 
>>> downloading and compiling the latest version of this driver but the 
>>> make process kept failing. I also tried to do this with the older 
>>> version of this driver (the bmc5700 one I believe is the name) from 
>>> Broadcom's site but the make failed the exact same way (complained 
>>> that a file or directory did not exist).
>>> This was all within version 6.06.1. I had my end user download and 
>>> install 7.04 of Kubuntu this morning and it was reported that the same 
>>> thing is happening. ARGHH!!!
>>> When I had it at version 6.06.1 I tried using insmod to load the 
>>> existing tg3.ko driver and it did appear when I ran lsmod but when I 
>>> tried to restart the network scripts it just complained that there was 
>>> no eth0 device.
>>> Has anyone got this working? Or... can you suggest a half height PCI 
>>> card we could install in the Dell that Kubuntu would recognize and we 
>>> could disable the onboard card?
>>> Thanks

More information about the ubuntu-users mailing list