Long Time Samba No Work-Need Expert Help On Samba/Networking-Ahhh, Some Success

Bruce Marshall bmarsh at bmarsh.com
Wed Aug 1 06:03:26 UTC 2007

On Tuesday 31 July 2007, Leonard Chatagnier wrote:
> > [root]    +++  added all of the below
> >       path = /
> >       force group = users
> >       writable = yes
> >       public = yes
> >       force user = bmarsh
> >       guest ok = yes
> >       read only = No
> Hey Bruce,
> Thanks for sharing your smb.conf. Not sure it would
> have helped me in my original problem as it is so
> different from the default and has no netbios name
> entry which what fixed me.  Do have some questions if
> you don't mind.
> 1. What is IP of? Before I solved my issue
> I had to enter the IP for my WixXP machine in
> interfaces before ubuntu would even list the shares in
> windows.  After the fix with the netbios name entry
> only lo and eth0 are in interfaces and everything
> works. So what does IP represent?

The  is the LAN address of the machine on which the smb.conf 
resides.   I have assigned all my machines addresses in the 192.168.0.xx  

Thus, one some other machine, the entry might be:

interfaces = eth0

> 2. What does the entry "include =
> /etc/samba/dhcp.conf"
> do? In my feisty setup, dhcp.conf is located in
> /etc/dhcp3/.  Maybe your using dapper or edgy? Is this
> a client or server setup? I have both the server and
> client setup on ubuntu machine but suspect I only need
> the client dhcp?

I guess that line is no longer needed.  Must have come from my SuSE distro 
when I ran that.   There is no such file in the current  /etc/samba

> 3. Is there some other entry in your smb.conf that
> takes the place of the netbios name entry in my setup.
> Not sure, but looks like you are using a domain name
> setup(I'm not) which may do the same thing. I'm not
> very network savy as you see.
> Thanks for your contribution,

Not that I am aware of.  I was surprised to make a check just now and see that 
even the workgroup name  isn't mentioned.

But here's a clue:  when I issue the   findsmb command, the response is:

root at linux1:/etc/samba# findsmb

---------------------------------------------------------------------     SRV1          +[SRV1] [Unix] [Samba 3.0.22-13.18-SUSE-CODE10]     LINUX1         [LINUX1] [Unix] [Samba 3.0.24]    WINMAIN1       [WINMAIN1] [Windows 5.1] [Windows 2000 LAN 
Manager]    KLINUX1       +[KLINUX1] [Unix] [Samba 3.0.24]

So it is using the names of the various machines as the NETBIOS name.

More information about the ubuntu-users mailing list