flashplugin-nonfree installation error code (1)

Kevin C. Smith kevin at linuxsmith.com
Wed Sep 20 15:34:32 UTC 2006

> On Wed, 2006-09-20 at 13:11 +0200, Luqman wrote:
>> hello,
>> realos at haqim-laptop:~$ sudo apt-get install flashplugin-nonfree
>> ..
>> dpkg: Fehler beim Bearbeiten von flashplugin-nonfree (--configure):
>>  Unterprozess post-installation script gab den Fehlerwert 1 zurück
>>  Fehler traten auf beim Bearbeiten von:
>>   flashplugin-nonfree
>>   E: Sub-process /usr/bin/dpkg returned an error code (1)
>> There is no problem with free space on my harddisk. Any idea what could
>> be wrong/solution is well appreciated.
> I got the same error message, but in english. I tried to do a reinstall
> of the package, but it did not help.
> /Magnus

It's an issue with the post install script. You can edit it to get the
install to work.

First try to install or upgrade it and let it fail.
sudo gedit /var/lib/dpkg/info/flashplugin-nonfree.postinst

Comment out the stuff after "# Automatically added by dh_installinit"

Should look like this when done:
# Automatically added by dh_installinit
#if [ -x "/etc/init.d/flashplugin-nonfree" ]; then
#       update-rc.d flashplugin-nonfree multiuser >/dev/null
#       if [ -x "`which invoke-rc.d 2>/dev/null`" ]; then
#               invoke-rc.d flashplugin-nonfree start || exit $?
#       else
#               /etc/init.d/flashplugin-nonfree start || exit $?
#       fi
# End automatically added section

sudo apt-get upgrade

Should install fine now.

Kevin C. Smith

More information about the ubuntu-users mailing list