How do I correct FSTAB?

Ted Quick rim_molder at
Mon Sep 18 13:36:44 UTC 2006

I just installed Kubuntu Edgy in a partition that had my first (somewhat flawed) copy of Kubuntu
Dapper in it. I have another (better working) copy of Dapper in a different partition.

Now I can start the new Edgy partition, but have no way to start the earlier Dapper partition
since it doesn't appear in the new fstab file. I tried editing the fstab file in Edgy by copying
the Dapper fstab into it.

THEN all I got for a while was a terminal screen when I tried booting up. Seemed to stop there,
but then this morning I just waited and it finally loaded the EDGY gui.

So right now the Egdy fstab file reads:

# /etc/fstab: static file system information.
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc /proc proc defaults 0 0
/dev/hda3 / ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid $
/dev/hda1 / ext3 nouser,defaults,errors=remount-ro,atime,auto,rw,dev,exec,suid $
/dev/hda6 none swap sw 0 0
/dev/hdb /media/cdrom0 udf,iso9660 user,atime,noauto,rw,dev,exec,suid 0 0

#Added by diskmounter utility
/dev/hdc1 /media/hdc1 vfat rw,user,fmask=0111,dmask=0000 0 0
#Added by diskmounter utility
/dev/hdc5 /media/hdc5 vfat rw,user,fmask=0111,dmask=0000 0 0

This is a direct copy of the earlier Dapper file. Dapper is on hda3, Edgy on hda1 BTW.

I also tried to change the Active partition using Qparted, at whichpoint it stopped booting up as

HOW do I change the FSTAB file to get the 3 way boot capability that I had before back?

Ted Quick
Need a website? Look at:

More information about the ubuntu-users mailing list