LANG=en_US.UTF_8

Claudio Clemens asturiolists at gmx.net
Tue Nov 21 15:31:27 UTC 2006


2006-11-17, 09:52 -0500, Gerald Drouillard:
> Not sure if this is a bug or not.
> 
> The above default LANG setting seems cause mc via putty to display the 
> box characters in weird characters.  It seems like Ubuntu ignores 
> .profile in the users directory and the only option is to set
> /etc/default/locale
> LANG="en_US"
> and not
> LANG="en_US.UTF_8"
> 
> The LANG setting in Mandriva 2007.0 is "en_US".

The Problem is that edgy only install UTF-8 locales, so your Putty is
trying to display UTF-8 characters with ISO fonts or something like
that.

I think there are 2 ways to solve the problem. Tell Putty to use UTF-8
fonts, or tell Ubuntu to use ISO-* charsets. Probably the first choice
is easier and better.

Do anybody knows how to get the ISO locales also genereted in Edgy?
dpkg-reconfigure locales doesn't work anymore.

Thats all folks,

Claudio

-- 
+- .''`. ---| Dipl.-Inf. Univ. Claudio Clemens |------| Sarge |-------+
| : :' :      asturio at gmx (.) net           GNU/Linux User #79942  |
| `. `'       http://asturio.gmxhome.de/begin.html                    |
|   `-        "YE GODS, I HAVE FEET??!"         <- Userfriendly       |
Drive A: not responding.. .Formating C: instead
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 189 bytes
Desc: Digital signature
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20061121/e2c0cd2c/attachment.pgp>


More information about the ubuntu-users mailing list