[RESOLVED] Re: Azureus crashes on edgy with sun-java5-jre

Scott geekboy at angrykeyboarder.com
Sat Nov 11 02:55:41 UTC 2006

Scott spake thusly on 11/10/2006 06:32 PM:
> Oliver Doepner spake thusly on 11/10/2006 01:39 PM:
>> Hi!
>> The bittorrent client Azureus crashes with SIGSEGV on my edgy system 
>> (i386) with sun-java5-jre. (all gcj packages removed)
>> See my bug report 
>> https://launchpad.net/distros/ubuntu/+source/azureus/+bug/71220
>> Any ideas how to solve this? My current workaround: I installed a 
>> vanilla Azureus in /opt which works without problems.
> Since you had no problem with your local install it sounds to me like
> there's a bug in the Ubuntu package.
> I'd stick with what you have if it's working.

I tried launching Azureus again and it crashed at the same place.

The third time I tried it worked.  In fact where it was crashing was
when I was trying to use it to create a directory for my downloaded
files.  Before I tried it the third time, I created the directory but
not from within Azureus.  Then I just selected the existing directory
from within Azureus.  Beyond that everything is working.  As of this
writing I've fully downloaded the file and I'm now just seeding it.

I've found Azureus somewhat buggy in the past. I guess things haven't
changed much.  It's by far the most feature-rich Bittorrent client out
there.  Perhaps it has too many features for it's own good?

That and the fact that it's Java-based. Java's always been a resource
hog (at least for me).

After I've decided that I've seeded this torrent sufficiently, I doubt
I'll be using it anymore.  KTorrent meets my needs just fine. It's very
very good.

© 2006 angrykeyboarder™ & Elmer Fudd. All Wights Wesewved

More information about the ubuntu-users mailing list