Shell Script question

Constantine Evans constantine at
Fri Nov 10 05:38:57 UTC 2006

This is not very helpful. Linda specifically said that the /usr/tmp 
directory is there and has proper permissions. Please read the questions 
being asked completely before offering advice.

As for the actual question, I'm not sure. Since you say this worked in 
the 1980s, I doubt that it is caused by the change from bash to dash for 
/bin/sh, though you could try changing the interpreter to bash to see if 
that helps. Other than that, I don't know what could be causing it. Does 
something like echo "Random Test" > /usr/tmp/testfile work?


F.J.Zhao wrote:
> In linux, the common place to put tmpfile is /tmp, not /usr/tmp. See
> FHS for detail explanation.
> 2006/10/25, Linda Hanigan <haniganwork at>:
>> I am migrating a bunch of programs from RH 7.3 to Ubuntu. I am having
>> problems with some of my  shell scripts. Below is the first lines of the
>> script through the line that causes the error and the error. This has
>> always worked even back to the 1980 with unix any idea what I need to
>> do? The /usr/tmp directory is present and rwx by the user running the
>> script. The script is suppose to create the file.
>> # Mprice_ prints missouiri price list
>> TEMP=/usr/tmp/price
>> show=MO
>> echo "What type of price list do you want? (Q P)"
>> read style
>> echo "How many copies do you want? "
>> read copies
>> echo "^[E
>> " > $TEMP
>> /usr/local/lbin/Tent/Mprice_: line 9: /usr/tmp/price: No such file or
>> direc tory
>> Thank you so much
>>         Linda
>> --
>> ubuntu-users mailing list
>> ubuntu-users at

More information about the ubuntu-users mailing list