IVTV firmware problems

Patrick Hilt pacadi at gmail.com
Wed Nov 8 06:46:40 UTC 2006

I have been banging my head against the wall with a WinTV PVR 350.
Here is the deal:
I followed the instructions here
(https://wiki.ubuntu.com/Install_IVTV_Edgy) to get the ivtv driver
working with a PVR 350 card and and a Via "epia m" board.

The first problem I ran into was that after the Edgy server install
the system would not boot. I figured out that that was related to the
server kernel being compiled for i686 (BTW that should be mentioned
somewhere) and the epia m being an i586 architecture. I fixed this by
booting from the Desktop live CD, chroot'ing into the server install
and installing the kernel, which is what I am
running right now.

Then I followed the instructions to install the ivtv driver as well as
its firmware (version When I modprobed ivtv, the
system hung after a short while with the following message: "ivtv0:
Error initializing firmware". I can't give a full log of what happened
as the system froze and there was no log after reboot but once on the
screen I was able to messages along the lines of: "encoder firmware
dead!" and "decoder firmware dead!"

I tried several firmware versions including pvr_1.18.21.22254_inf.zip
but no change. It just keeps hanging...

Any idea anyone?
Again specs: Epia M, PVR350, Ubuntu server with kernel

Thanks for any help!!!

More information about the ubuntu-users mailing list