Edgy Install Problem x11-common

Chris Lamb chris at thelambchops.net
Wed Nov 1 14:43:55 UTC 2006

Quoting golfer <golfbuf at gmail.com>:

> On 10/31/06, Chris Lamb <chris at thelambchops.net> wrote:
> > The following is my problem:
> > ----------------------------
> > Preparing to replace x11-common 7.0.0-0ubuntu45 (using .../X11-common_1%
> > 3a7.1.1ubuntu6_i386.deb) ...
> > Unpacking replacement x11-common ...
> > Replacing files in old package xinit ...
> > dpkg: error processing /var/cache/apt/archives/x11-common_1%
> > 3a7.1.1ubuntu6_i386.deb (--unpack):
> >   trying to overwrite '/usr/X11R6/bin', which is also in package xgl
> > Selecting previously deselected package xutils-dev.
> > Unpacking xutils-dev (from .../xutils-dev_1%3a1.0.2-3ubuntu3_i386.deb) ...
> > Errors were encountered while processing:
> >   /var/cache/apt/archives/X11-common_1%3a7.1.1ubuntu6_i386.deb
> > E: Sub-process /usr/bin/dpkg returned an error code (1)
> > ----------------------------
> >
> > This error was received after attempting to do the upgrade through the GUI.
>  I
> > received a message about not being able to write to the /usr/X11R6/bin
> > directory because it wasn't empty.  There was an Xgl link file in there
> which I
> > deleted.  (I tried to install Xgl a while back but it didn't work.) 
> Further
> > upgrade attempts failed. After rebooting, X will not come up.
> >
> > I have noticed similar errors in the forums and other emails regarding
> xinit
> > and xterm.  So far, none of the suggested fixes for those problems fix my
> > problem.  I've tried "sudo apt-get remove --purge xgl" and it gives me more
> x11-
> > common error messages.
> >
> > I would give more detailed messages but am not currently at my computer to
> be
> > able to troubleshoot.  I thought I would post this, though, in case
> someone
> > else has experienced it or to see if there was a known solution.  Barring
> a
> > known solution, I think I will just have to rebuild.
> >
> You may have success using 'dpkg -P xserver-xgl' instead of apt-get.
> You can check if it's removed by 'dpkg -l | grep xgl' to see if it's
> fully gone or some config remains.  Also, try 'dpkg -P x11-common' to
> remove it, then 'dpkg -i --force-overwrite
> x11-common_7.1.1ubuntu6_i386.deb' to install with forcing.

I started rebuilding another box last night but I will try these on the broken 
box so I can learn something.  I'm a little OCD when it comes to having a clean 
box and when one is broken and I don't know why or how to fix it, I end up 
starting fresh.

> > If I do rebuild, is there a way from the command line to archive my
> Evolution
> > emails/contacts for use in the fresh build?
> >
> I'm not familiar with evolution, but it must keep your contacts and
> such in a directory in your home, so use 'ls -a' in your home
> directory to see if anything looks like it's related to evolution
> (i.e. ~/.evolution).  If there is something labelled evolution, just
> use 'tar cjvf evolution-files.tar.gz <the directory name here>' in the
> terminal and it will pack it up in an archive .. then you need to copy
> 'cp evolution-files.tar.gz /dev/floppy' or some place for safe
> keeping.  Once you've reinstalled, just copy it back and double click
> on it to get ark to open it.

This worked great.  I haven't looked at exactly how the configuration worked 
because when I opened Evolution on a fresh install it still asked for account 
information.  Not sure if it duplicated an account or what, but all the old 
emails and contacts were there.


> > Thanks for any help!
> > Chris
> >
> -- 
> ubuntu-users mailing list
> ubuntu-users at lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-users

More information about the ubuntu-users mailing list