Dapper upgrade with resolvconf not working on startup

Adam Done emlists at gmail.com
Tue Mar 28 07:15:55 UTC 2006

Adam Done wrote:

>I have another partition on my Powerbook in which I copied my breezy
>over and upgraded all the files to Dapper.  However once I have, my
>resolvconfig stopped updating the name servers upon a fresh
>start/restart.  I have been able to update the resolv.conf file in the
>terminal issuing '/etc/init.d/network restart' and the nameserver gets
>added from my /etc/network/interfaces file as it should on a boot. 
>After some vigorous testing I have concluded thus far...  
>1.  none of my startup scripts in my rc5.d directory is hindering
>resolvconfig to update properly on boot. (Had to rule that out of the
>list of variables.)
>2.  I have noticed in Dapper ifupdown is not started on boot nor is
>there a script for it in /etc/init.d as there was in Breezy and started
>after the resolvconf script starts.
>3.  I tried to start the networking script later in the boot process
>('S99networking' to make sure) but that has not changed anything with
>4.  Changed the dpkg settings which resulted as the same.
>5.  I have turned off and on various rcS.d scripts with the end results
>being the same.
>6.  Checked and even copied my /etc/network directory from breezy over
>to dapper and still the same.
>7.  Uninstall/reinstall/deleted resconf but all the same.
>After my testing I have concluded the issues lies with my resolvconf
>script which is not getting setup properly on boot to accept a network
>I  am on a 15" Ti Powerbook and float between different networks and
>have since this time have resolvconf update my nameserver info when
>changing networks/interfaces.  I am mostly on static networks but do
>connect at times through dhcp on/with other networks.   ALL my testing
>have been on a static network so there are not any confusions of extra
>variables with DHCP.  I am very perplexed as to why and what may be
>hindering my resolconf to update my nameserver info upon network startup
>on boot.  I  am looking for extra help to bring this issue to a close.

Well... after uninstalling resolvconf and not being able to change the
resolv.conf on the fly I installed it back and created a small hack of a
startup script to restart the network right after the network services
were started.  This is a fix till I can figure out why without restating
the network services resolv.conf does not update properly.


More information about the ubuntu-users mailing list