Problems Playing Videos

JimD Jim at
Sun Jun 25 05:30:30 UTC 2006

aljones15 wrote:
> I actually have the same problem. If I watch one video on youtube then
> close the window suddenly I have no sound for any of the other
> applications including the web brosweer. I've tried killall esd (which
> worked with the last version of ubuntu), but now it doesn't.
> peace,
> A

You should try not to use esound at all.  Alsa does sound mixing and has 
a compatibility module for old OSS apps.  Here is what I have set up and 
it seems to work:

In /etc/modules I added snd-seq-oss so the alsa oss module is loaded at 
boot.  You can manually loaded it with "modprobe snd-seq-oss" so you 
don't have to reboot.

Install alsa-oss:  sudo apt-get alsa-oss

This will give you /usr/bin/aoss.  You can run an old OSS program with 
aoss like so:

aoss realplay

Now realplay will work while other alsa apps are playing and also 
realplay will not lock your sound card.

I just modified the /usr/bin/realplay startup script to always launch 
realplay through aoss.  Here are the changes I made that are near the 
end of /usr/bin/realplay:

#LD_PRELOAD=`echo $LD_PRELOAD | sed -e 
#export LD_PRELOAD

#if [ -n "$LD_PRELOAD" ]; then
#    echo "Warning: LD_PRELOAD=\"$LD_PRELOAD\""

# execute binary (and pass args), optionally running via catchsegv
REALPLAYBIN="/usr/bin/aoss $HELIX_LIBS/realplay.bin"

Basically just comment out the LD_PRELOAD lines and add /usr/bin/aoss to 

I just tried YouTube, which uses flash, and it would not play if I was 
playing an mp3 through mplayer.  I then launched Firefox through aoss 
and both played at the same time.  To get firefox to run flash through 
aoss, just open /usr/bin/firefox and find this line:


change it to:

MOZ_PROGRAM="/usr/bin/aoss ${MOZ_DIST_BIN}/firefox-bin"


         (o o)
|  You roll an 18 in Dex and see if you  |
|  don't end up with a girlfriend        |
|  JimD - Central FL, USA, Earth, Sol    |

More information about the ubuntu-users mailing list