Kernel Compilation Woes [was Re: iPod Isssues]

Ylan Segal ylan.segal at
Fri Jun 23 13:00:34 UTC 2006

Brian McKee wrote:
> Here's that link I was looking for

OK, so after reading the link you provided and poking around the
Internet some more, I decided to roll up my sleeves and try to compile
my own custom kernel in order to get my iPod working. I got my nose
bloody a few times along the way but finally got the kernel to compile
like this: (but keep reading, I still have problems)

[DISCLAIMER: I am not a Linux guru, nor play one on this mailing list.
This instructions worked for me on Ubuntu Dapper, follow at your own

# sudo apt-get install linux-kernel-devel linux-source kernel-package
ncurses-dev gawk
# cd /usr/src
# sudo untar --bzip2 -xfv linux-source-2.X.X.tar.bz2
# sudo ln -s linux-source-2.X.X linux
# cd linux
# sudo make oldconfig
# sudo make xcongfig
(Make changes in configuration using graphical interface. In my case I
disabled EFI support by going to File Systems -> Partition Types ->
Advacned Partition Selection -> EFI GUID Partition support)
# sudo make-kpkg clean
# sudo make-kpkg --initrd --append-to-version=-ylan kernel-image
# cd /usr/src
# sudo dpkg -i kernel-image-2.6...deb (I used actual file name here)
# sudo dpkg -i kernel-headers-2.6...deb (I used actual file name here)

Now, come the questions: Currently I am running Ubuntu 6.06 (dapper)
with Kernel (originally it was but the version on
my custom compiled kernel is How can that be? Where did I get
that version from?

Anyway, I ignored that for a minute and decided to test it, went ahead
and rebooted and selected the newly compiled kernel. The system starts
fine, I log in to gnome and quickly realize that my wireless Internet
connection is not working. If I click on the network manager icon I get
the following error message:

"Please contact you system administrator to resolve the following problem:
SIOCGFLAGS error: No such device"

In the network configuration my wireless card is also not displayed (the
ethernet card is and after enabling it, it works fine). So, what
happened to my wireless? How can I get it back? If I boot with kernel all is well. Before you ask: Both the ethernet and wifi are
built in my Sony Vaio laptop (with Centrino processor).

Since I thought that the wireless might be related to using an old
source, I removed the custom kernel, cleared the apt-get cache and
reinstalled the linux-source (it downloaded again from the Internet). I
left the kernel compiling again today before leaving for work. Will this
make a difference?

Oh, I almost forgot: I didn't even test if my iPod worked with the
custom compiled kernel, which is why I compiled it for in the first
place ;)-


"The universe is not required to be in
perfect harmony with human ambition"
~ Carl Sagan

More information about the ubuntu-users mailing list