Getting wifi to work

Henk Koster H.A.J.Koster at
Tue Jun 13 06:39:34 UTC 2006

On Mon, 12 Jun 2006 23:18:08 +0200, Alexander Skwar wrote:

> Hello.
> Despite the fact, that I'm not yet able to install Ubuntu on my HD, I'd
> like to get my wireless card to work.
> I'm using a "Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)"
> which uses the madwifi driver. The AP is a Linksys WRT-54GS running
> OpenWrt firmware. I'm using WEP.
> According to <>, I need
> to do "sudo iwpriv authmode 2", as I'm using WEP. After I ran that command,
> which returned nothing and I thus expect that it succeeded, I started
> the network admin tool from (System)->(Administration)->(Networking) and
> selected the ath0 device, which got created automatically during boot.
> I then selected "settings" and entered my hex WEP key. For the key, I
> tried it with and without dashes, ie.
> 	3D26-72EE-AFFE-7EE1-5FDD-8A1E-77
> 	3D2672EEAFFE7EE15FDD8A1E77
> (that's not the actual key...). When I then activated ath0, it took
> quite some time and in /var/log/daemon.log I could see, that dhclient
> was trying to get a DHCP response. It didn't get one.
> Well - what to do next?
> Thanks,
> Alexander Skwar

You're booted from the Dapper liveCD, I take it? And does dmesg 
show that the madwifi driver is loaded and recognizes your NIC?

Then all you need to do is open the System -> Administration ->
Networking menu, select the ath0 interface and hit Properties.
Then select the essid, enter the hex WEP key and select DHCP. 
After accepting these settings, activating the interface should 

I don't see where the wiki adds anything of use (but it did a 
year ago).  

More information about the ubuntu-users mailing list