(no subject)

abetterturkey abetterturkey at hushmail.com
Mon Jan 30 03:10:48 UTC 2006

Hash: SHA1

I've installed Ubuntu Breezy for some family members who are using
it and loving it, having no problems with it in their move from
Windows. No problems that is, until a few days ago when I was
summoned to help them with an error they demonstrated for me when
trying to mount a floppy and write to it in KDE 3.5.0, it just
didn't work. (I installed kubuntu-desktop for them following an
install of ubuntu and they prefer to use KDE)

"This should be something simple!" several of them cried, reminding
me of how easy it is for them to do this in Windows.

I was sure that this was really something simple and put the floppy
in and it said it couldn't determine the filesystem. I had never
seen this issue with Linux before, and I've used several
distributions. Naturally when I went to the command line I could
mount the floppy using sudo with the vfat option and I quickly
wrote the files they wanted to the floppy.

This is all well and good for this time, but they can and won't use
the command line in Ubuntu, nor did they use it in Windows when
they used Windows. I managed to modify /etc/fstab and change 'auto'
for the floppy drive to 'vfat' and the floppies now mount correctly
without an error message, (which is fine because the only floppies
they use are formatted with fat to use on other windows systems)
the trouble is nothing can be written to them without again going
to the command line and using sudo to copy the files. I've read
through all of the Ubuntu Forums threads with 'floppy' in the
subject line, I've tried all of the tips and tricks suggested, but
nothing works in allowing write access in a GUI in Ubuntu Breezy. I
even tried one suggestion to chmod 777 the floppy drive and reboot,
it just does not work.

My /etc/fstab line for the floppy currently is as so:

/dev/fd0        /media/floppy0  vfat    rw,user,noauto  0       0

The above allows mounting but not writing.

How may I solve this issue so my family can write to these floppies
when they're mounted? I can't take anymore of this "well it works
in Windows" type of jeering any longer and they are correct that
this should be something simple, but I cannot grasp any way to
solve it.

I moved them from SUSE to Ubuntu because SUSE 10 had a strange bug
with slow moving of files from the hard drive to USB thumb drives
and now this little experience with the lack of write access to
floppies in Ubuntu is driving me insane. This is the only problem
they have with Ubuntu Breezy, and they use floppies often. I don't,
which explains why until they brought this problem up I never knew
it existed.

Is there a clear and simple solution? I am begging you, please help
me solve this so I can shake the "it works in Windows!" parrots
from my back! :P
Note: This signature can be verified at https://www.hushtools.com/verify
Version: Hush 2.4


Concerned about your privacy? Instantly send FREE secure email, no account required

Get the best prices on SSL certificates from Hushmail

More information about the ubuntu-users mailing list