kernels and hotplug

crimsun at fungus.sh.nu crimsun at fungus.sh.nu
Sun Jan 15 16:40:29 UTC 2006


On Sun, Jan 15, 2006 at 03:16:30PM +0000, Toby Kelsey wrote:
> I decided to start testing the unstable Dapper version by installing the
> latest kernel.  However when I selected linux-image-2.6.15-12-686
> Synaptic informed it must *remove* hotplug as a prerequisite.

That's correct. Dapper has migrated away from hotplug, because 2.6.15
and udev have subsumed its functionality.

If you choose to run a Dapper kernel on a Breezy system, you will need
to backport Dapper's udev as well. *** Note that this removes hotplug,
so you will only be able to run 2.6.15 on your Breezy system.

> If this is not just a bug in the dependencies, it seems to show that the
> Ubuntu developers no longer try to keep install compatibility between
> different kernels.  Is the policy now to only support having one kernel
> installed?

No, this is a side effect of migrating to Dapper.
-- 
Daniel T. Chen            crimsun at ubuntu.com
GPG key:   www.sh.nu/~crimsun/pubkey.gpg.asc
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20060115/de2aac5f/attachment.pgp>


More information about the ubuntu-users mailing list