udev permission problem - dvd-ram mounts only read/writeable for root

Michael Vert vmike at gmx.net
Thu Feb 16 09:37:43 UTC 2006

Phillip Susi wrote:
> Do you have an entry for this drive in /etc/fstab?  AFAIK,

I tried it both ways - with and without...
By now I can get access to the DVDRAM with a correctly created
/erc/fstab entry... but not to the files on the DVDRAM (see below).

> gnome-volume-manager does not run until you log in, so it can't mount
> the media with uid=root. 


> If you have an entry in your /etc/fstab
> though, that will be used to mount it at boot time, and g-v-m will use
> those settings as well, rather than the defaults, which specify the uid
> of the currently logged in user.

As I found out meanwhile, that there is a bug in the kernel regarding
access to UDF file systems which has been solved in 2.6.15-mm ...

If gid and uid values are present in the mount options (they are), they
should overwrite any uids/gids from the drive (which they don't do at
the moment).
I can create a file as a normal user on the DVD-RAM, which I can access
during this session. If I now eject the DVD-RAM and then remount it, all
files have the permissions: root:root 700 (the same goes for
directories, which makes them hard to access).
Let's hope the fix makes it fast into the current kernel.

More information about the ubuntu-users mailing list